Problem sending data to the laser!


(Franco Azzolini) #1

Hi Everyone

I just exchanged the computer which I use for the Shapeko3 with a Laser attached, from a 10" tablet with Windows 10 to a desktop computer with Windows 7 Pro installed. I followed the instructions to download all of the software needed for the laser like Java and Firmware with the X Loader, etc. I am using the Lightburn software. Now when I try to turn the laser on the laser light comes on and the fan is running but I am getting the message: There is a problem sending data to the laser.

I had some problem with different web pages such as Git Hub is not supporting Internet Explorer, Java is not supporting Chrome and so on. It is frustrating not knowing if everything is correctly installed, though I have the Java Icon on my screen and the X Loader showed that it had downloaded.

Can anyone think of anything else that I was supposed to download in order to get the laser working properly?

I also tried to get back to the CNC settings and I unplugged the cables from the laser and the X-Y Axis are working fine, but the Z Axis is not working right. It gives a horrible rattling noise and I notice that the laser runs in Port COM 3 and the CNC before I hooked up the laser was on COM 5. I tried to change the COM # in the Universal G code sender back to 5, but it doesn’t accept the COM 5. ?

I would like to know how to solve the problem of the data not being sent to the laser and why the Z Axis is not functioning up and down.

PS: Thanks to all who helped me before Christmas with my setup !


(Neil Ferreri) #2

Did you use xloader for anything? You don’t need to change the firmware on the machine controller. Maybe you changed settings?
Can you post your grbl settings? Send $$ to the controller.
Does lightburn change any settings?


(Phil Gorsuch) #3

Hrmmm. No expert here but the words ‘firmware’ and X Loader make me think you flashed the firmware for something else onto the Carbide3D controller? That might one source of your troubles returning to CNC mode - would probably need to reflash back to the Carbide3D GRBL firmware…


(Franco Azzolini) #4

Hi Phil and Neil !
Thank you both for your response to my questions.
I tried to download the GRB G Code Sender but I always end up getting this .hex file and to upload this hex file I needed the X Loader. So I downloaded the X loader and like the instructions stated, I loaded this grbl_v1.1f.hex file over to my CNC controller. When I did this the first time with my tablet it worked fine. I just can not get it to work after I changed it over to my desk top PC.
I am not quite sure how to copy the grbl settings to the notepad. But I will try to get a copy from these grbl settings and post it here as soon as I figure it out!


(Neil Ferreri) #5

Do you know that you had 1.1f installed previously. If you upgraded your firmware (most likely from v0.9), then you probably lost your grbl settings.
We’d have to know more about your setup to help beyond that. If you send $$ to the machine, it will report back with your settings. Just copy and paste them here.


(mikep) #6

Just FYI: use the updater, here -> https://docs.carbide3d.com/support/carbideupdater/ . and don’t mess with the hex file and xloader.

The comments about settings above are important - as is the version of CM you’re using.


(Franco Azzolini) #7

Hi Neil,
My settings:
Grbl 1.1f [’$’ for help]

$$
$0=10
$1=255
$2=0
$3=6
$4=0
$5=0
$6=0
$10=255
$11=0.020
$12=0.010
$13=0
$20=0
$21=0
$22=0
$23=0
$24=100.000
$25=1000.000
$26=25
$27=5.000
$30=1
$31=0
$32=0
$100=40.000
$101=40.000
$102=40.000
$110=5000.000
$111=5000.000
$112=5000.000
$120=400.000
$121=400.000
$122=400.000
$130=425.000
$131=465.000
$132=80.000

Thanks
Franco


(Neil Ferreri) #8

@franazzo Nothing there is standing out to me to give you the Z-axis issues. Usually a

is caused by something mechanical. Could the Z belt /pulley be loose or reaching its limit?
Are you using Carbide Motion? Which version? With 1.1, you should be using CM4.


(Franco Azzolini) #9

Hi Mike
I finally have my software running again(Lightburn). If I do use the Updater, does this mean that it will delete my laser settings? Will doing this, bring it back to the factory reset settings? Thanks


(Franco Azzolini) #10

Thanks Neil, I checked everything last night. The pulley and the belt seem to be fine but I think one pin plugged in the control board was perhaps too loose!?!? So the laser is working again:-) . I just can not find anything how to make the switch back to use the router again. I am not using the Carbide Motion. I am using Universal G Code Sender and G Code Sender does not allow me to change the ports. It only shows COM3.


(Neil Ferreri) #11

You don’t need to change the ports unless you’re changing controllers (the board controlling your machine).

What’s not working? Do you have the router setup to turn on and off automatically?


(Franco Azzolini) #12

I turn the router manually off and the Z axis is still the problem.


(mikep) #13

NO. Changing the firmware always wipes out settings. If you run 1.1 grbl, you need CM4 to set them. If you run .9 grbl, you need CM3.

Why won’t lightburn use grbl 1.1? grbl 1.1 has some nice laser features that .9 doesn’t. You really shouldn’t need to swap firmware.


(William Adams) #14

Swapping firmware is also a concern because the EEPROM has a finite number of writes — I know it’s supposed to take longer than the board is likely to be usable, but it just takes one failure of one memory location to brick the machine.


(Franco Azzolini) #15

Hi Mike, I noticed that: You must have homing switches on your machine .
I don’t have a homing switch, so I have to look for an other solution.
Thank you for your help and time.


(mikep) #16

Then you can’t use CM4.


(Neil Ferreri) #17

@franazzo Can you describe what you’re trying, with what software, and what results you’re getting?


(William Adams) #18

To revert to Grbl 0.9 so that you can use Carbide Motion 3 and not need homing switches please see:


(Franco Azzolini) #19

I am trying to use my CNC again after I installed the Lightburn software. The Z axis is comp lit out of wack.
I will try to change the GRBL 1.1f back to 0.9


(Franco Azzolini) #20

Hi Wil
I think I need to start fresh with the whole mess. I will report back. Thanks again.