Problem with CM4 upgrade

(William Adams) #21

The MACOSX files should be metadata left over from preparing the archive on a Mac and can be ignored/deleted.

If you have 1.1f, installed, then all you should need to do is install CM4 and use that.

If you have trouble sending the defaults, just send them manually.

(Kimothy Ehster) #22

I haven’t installed it yet, and how would I install the defaults manually? I apologize for taking up so much of your time, but am grateful for the help and advice.

(William Adams) #23

Crib the settings from: and

Check in w/ — obviously we need to work up a canonical list of the Grbl 1.1 defaults for each machine.

(Kimothy Ehster) #24

Hi Will,
I worked with Brandon on this problem, and we found that the Z limit switch was bad. I put a new one on and started CM4 and hit jog and it started homing and Z worked great but Y kept hitting the side. I did a continuity check on both Y and X switches and there is continuity there, but are the switches NO or NC? I get continuity when I push the buttons on the switches.

(William Adams) #25

I believe the switches are NO since a jumper works to upgrade.

(Kimothy Ehster) #26

OK thanks. I will have to do some looking on here to see what could be the problem. The switches are working right if they should be NO.
Thanks again!!