Problem with CM4 upgrade

I flashed my XXL to GRBL1.1 and tried to upgrade to CM4, but I don’t get a toggle button for enabling homing. I open the log and it just keeps scrolling the same numbers over and over. I do have a Super PID on it, but don’t know why that would affect it. Anyone else run into this and if so how doI fix it? Thanks

Homing is always enabled (and required) for cm4. The numbers you see go by are the status of the board being reported to cm4. This is all normal.

1 Like

I loaded a file and went to jog the machine and my router started going down and then quit giving me these errors:
Error (7) : Limit switch error (Z)
Error (8) : Homing Cycle Failed
Error (9) : GRBL ERROR: Homing Failed, Pull off didn’t clear.
Something tells me I should have left well enough alone and stuck with CM V3

Did you send the settings for xxl via cm4?

Yes I did. Why would Z go down when homing when the switch is above?

likely because the Z direction bit is backwards.

1 Like

The Z-axis can be reversed for a couple of reasons — the most usual is that the Z-axis plate is installed upside down.

The community has a basic page on this here:

The Z axis plate is installed correctly. It worked right when I was using CM V3, and that is what has me puzzled.

In that case, you must have reversed the Z-axis setting either in Grbl 0.9, or when you updated to 1.1, or it may be that you haven’t updated the settings of Grbl 1.1 — see: for the latter

If you need to reverse the Z-axis manually, see:

This is the settings screen that I get

Yes, that’s the one — be sure to re-send the settings if you haven’t — the toggle homing button you see on the screen grab in the docs isn’t there anymore.

This is the screen I get after I send the settings. As you can see, it doesn’t have the correct model in the box, and when I try to open and home it just starts to lower the Z instead of moving up, and I get the same errors as listed above.

Forgot to attach the photo

I left the firmware at 1.1 and went back to CM V3, and I am running a program without running the router just to see if it is working correctly, and so far, so good. I’m not going to worry about V4 right now if this works.

I suspect you’re still on Grbl 0.9 — please check, Grbl 1.1 w/ EDIT: CM3 is not supported. (EDIT: Grbl 1.1 works with CM4 — that and Probe support are why we have it)

See GRBL 1.1 and Carbide Motion 4 to revert.

Err…Will mistyped.

OK: GRBL .9 with CM3
OK: GRBL 1.1 with CM4

no other configurations work. You cannot reliably use 1.1 with CM3. If you sent settings before upgrading, they are wiped out on the upgrade. There is a very specific order this upgrade has to be done in.

1 Like

IDK, but as you can see the Shapeoko is running GRBL version 1.1 and Carbide Motion 3, and I just loaded and cut the project in the picture. It runs great, and none of the usual skipping when jogging. ???

There have been some pretty unusual problems caused by running Grbl 1.1 with CM3 — it’s neither supported nor recommended.

1 Like

And your homing switches are turned off.

Good luck.

1 Like

OK, I Followed the instructions in the link from Will and tried to go back to 0.9 and CM V3, and it didn’t work at all. I am going to retry 1.1 with CM4, but in the updater I have 2 files. One is MACOSX, and the other is Carbide GRBL updater. Do i have to install both files? Please pardon my ignorance on this, but it is getting the best of me.