Problem with drilling with CC

Hey all

Trying to use CC to do the g-code for a cribbage board. Board has a ton of 1/8" holes for the pegs, which I drew in my Cadd program and imported into CC as a DXF file. So far so good.

The problem comes when I try to create g-code. Since the bit size is 1/8" and the hole size is also 1/8", the program refuses to generate a proper g-code file. It’s just like it doesn’t see the holes, they do not show up in the simulation. I tried all the types of holes, if I select outside or no offset, it will do a g-code file, but the results are wrong.

If I edit the tool size and make it a couple of thou smaller than the hole, it will generate proper code. It also seems to work properly if I use a 1/16" bit instead of a 1/8" bit to generate the g-code. I don’t have any bits smaler than 1/8", so that is not an option. Is there something I am missing? Is there a special way to do straight drilling rather than routing?

Another issue I am running into is that CC is VERY SLOW when doing a lot of small holes. Recalculating the display can take up to 5 minutes. I have a fast 8 core processor and 16GB or RAM, as well as a fast video card, but it seems the program only uses 1 processor core. This is very annoying especially when trying to troubleshoot, it takes forever to regenerate the image. Windoews just keeps telling me the program is not responding until its finished.


1 Like

You can’t drill in CC, only route with a smaller bit (1/16" would be where I would go with this). If the holes don’t have to be “perfectly” 1/8", you could always upsize them to a radius of 0.063" (0.126" diameter). For a cribbage board I think that would still be about right assuming your pegs are 1/8" (do a test cut on a piece of scrap to verify fit). It just wont do any pockets same size as tool (or smaller obviously). I use Vectric VCarve most of the time which allows peck drilling and use a drill bit instead of an end mill.

Yes, CC is very slow when doing a lot of toolpaths. You can unselect the tool paths when doing all positioning, then activate them just prior to preview/exporting GCode which might help. I mentioned this some time ago here:

That flag pretty much stops my PC when trying to do anything, even loading the file itself. However the GCode came out just fine, just took forever to do the drawing and tool paths. CC is a pretty cool tool and simple to use, pretty limited…but free!



As @DanoInTx noted, we don’t do drilling — w/o a perfectly calibrated plunge rate and spindle speed the machine deflects resulting in a lozenge shaped hole.

You’ve got three options here:

  • use a tool which supports drilling — MakerCAM is one, and there’s Gsharp which will convert peck-drill G-Code commands into step-by-step instructions Grbl will accept — this will require that you get the plunge and speeds just so — if you use a drill bit, then you will need to source one which has specifications which match the speeds at which one can spin the spindle
  • enlarge the holes so that they are at least 10% larger than the endmill
  • use a smaller endmill — 3mm isn’t quite small enough, and I’m not aware of 2.75, so 2.5mm?

In terms of speed and efficiency, again you have a couple of options:

1 Like

You got it 100% correct.

We can continue to pray that we get a drilling operation in CC…until then I use Fusion 360 for my drilling cycles…

You would think adding it would be easy…and something that would have been done years ago.


Will. I can’t see anywhere where carbide create will acknowledge that I have a 2.5mm or 3mm bit. All I see is .063 or .125. Any help would be appreciated. Thank you

If you select a tool before clicking on “Add Tool” the selected tool will be used as a template for the new one.

  • Toolpath
  • Edit Library
  • Add Tool
  • double-click on the new tool to go into edit mode
  • edit as needed
  • Ok
  • close window
1 Like

This seems to come up so often CC should flag and show an error when people try doing this and explain to then that it doesn’t support drilling.

1 Like