Question about cutting depth and simulation

I am trying to make the Rambone slingshot popularized by Winston on his Shapeoko you tube video.

I put loaded one of the pieces into Meshcam and added 1.6mm to the stock thickness that Meshcam provides after loading the STL. The STL is about 17.5mm thick and Meshcam gives that as the Z dimension of the stock, I have 19mm stock so I added 1.6mm to the Z dimension of the stock as shown below

I set up the tool path parameters shown in the screen shot below.

The Meshcam simulation shows the top of the stock being cut, about 1.6mm which is what I expected so as to make the 17.5mm thick part. The simulation also shows the part being cut all the way through the 19mm thick stock.

When I run the program on the Nomad and cut the part, the top surface is not cut as shown in the simulation, and the part is only cut 17.5mm deep so it does not separate from the stock.

In the toolpath parameters the ‘don’t machine top of stock’ is not selected and the max cutting depth shows 19.1mm

What did I do wrong?

The simulation looked good, but the part did not have the correct cutting depth and in did not machine about 1.6mm of the top of the stock as expected.

I am missing something, but cannot quite see it yet.

I tried cutting the part again and this time the program ran for a bit then it moved off the cutting path and into the main body of the slingshot so I stopped the cut. Sigh…

What should I be looking at to try and get this part made?

(I also tried running the STL through Netfab to fix any open triangles but that did not address this problem either…)

(The Rambone STL is too thick to cut from one piece so I used Meshcam to slice it into 3 STL’s and then cut them separately. This particular STL needed to be rotated 180 degrees in the X axis to get the flat part down. The second part that worked did not have to be rotated in Meshcam)

Steve, you are 90% of the way there. The toolpath screenshot shows the problem. The Program Zero Z zero is not on the corner of the stock, but still on the Z zero of the geometry. After you redefine the stock, you need to redefine the Program Zero to the corner of the actual stock.

I imagine that the Nomad went through the motions of cutting the Rambone, but was “air cutting” assuming you zeroed the bit on the top of the stock.

Years ago I requested Rob to order the CAM menu items like this

because that is the general workflow. Most of the items need to be addressed before you come to the Generate Toolpath item.

If you have the stock still in place on the table, you should be able to re-cut it just by re-zeroing the cutter Z on the stock. The Nomad is very very good at repeatability of zeroing the axes between powerups (by my testing, within .001" / .03mm)

BTW please do report back on the Rambone. I have the solid model but have not tried machining one yet…


I have not quite got it yet, and have a couple of questions…

If the Zero is off, then why does the simulation show the top being machined and on the actual stock it is not? I thought if I checked the simulation and things looked good then I would be ok. There is something I am not yet getting right.

The screen shot below is zoomed in on the STL view and shows the Z position being slightly below the top of the material. In the Program Zero menu I clicked on the top left corner and set the Z position to Zero. Why is it then below the top of the stock?

The screen shot below shows how I added 2mm around X and Y for the cutter to have room to work, and the 1.6mm at the top because the board is 19mm thick and the STL is only 17.4mm thick. Do I need to do this differently?

Steve,did you reset the Program Zero after you adjusted the stock thickness? That is the only thing I can think of to explain. Any time you adjust stock size, you need to reset Program Zero, and Max Depth if you have it set to a particular value. Any supports you have added will rebuild though.


You nailed it, I had tweaked the stock thickness after adjusting the Zero and did not go back to set the zero after that. Slicing the Rambone SL into three sections results in the zero for some of the STL sections being in odd places. Once I got the stock zero to the top, and upper left corner, things were fine. I cut the three sections out of pine, its cheap while I am learning, and with some sanding and gluing I should have a light duty slingshot, see pic’s below.

Another question, what exactly does the number in the Z-position box in the program zero box represent? I kept wanting it to read zero to represent the top of the stock, but that does not look like what it is. The zero on the STL slice is in the upper right hand corner, see screen shot below, and I am wondering if the number in the Z box is the difference between the top of the stock and the zero point of the STL?? Anyway, just clicking on the left side box in the top of the Program zero window makes everything work out, it just leaves me with a number in the Z box, highlighted in the screen shot below, that I do not yet understand.

Thank you so much for your help with this. We have a very happy Nomad camper up here in the Northwest… :smile:

Steve, that’s looking good! I don’t know what the number in the Z box means. I’d think it was an offset from the geometry zero to the Program Zero but from your earlier screenshots that does not seem to be the case here. I’ve never done a sliced job so I can’t speak to that. I either use the “top of stock” click box or Set to Geometry Zero when I’ve exported an STL with a specific origin (usually to coordinate with other machining processes). And you’re welcome. MeshCAM is not always intuitive, and it would be nice for more things to be associative (like the Program Zero following the stock corner when you readjust the stock) but it is consistent in behavior which is the most important feature.

You might try reloading the slice and setting up the stock, and then click on Set to Geometry Zero and see what the X Y Z readouts say, then click on the pictures to reset to the stock corner and see what the readouts say then and compare.