Questions about new 2.4d board

My new 2.4d board should be here on Monday. I have a pretty short (3’) USB cable already, I’ve ordered one of the Tripp Lite cables w/ chokes on it, though. I’ve been trying pretty short (5’) cables with chokes, and cables that have heavily braided shields.

Will I still need to get the chokes for my router power cable? I don’t have those now. I had read others didn’t really have much luck with them.

Or is the 2.4 board just going to fix an underlying issue so the rest of the solutions go away?

My disconnects come when powering-off the router. And I want to work on a project where I will need to do that a few times, so I need things to get stable.

I have a 2.2 board now. I tried the 2200uf capacitor and it didn’t really help at all. I swapped to a 1000uf and same thing. Maybe the 2.2 board is just old enough that the capacitor doesn’t help enough. Maybe the people experiencing success w/ the capacitor weren’t concerned with disconnects at spindle-off.

I called FedEx today and explained I had a package (the 2.4 board)that was shipped 3-day air but that it has been at the FedEx facility since last evening and it isn’t scheduled for delivery until Monday. I asked if there was a chance I could pickup the package at the facility today or tomorrow.

The answer is that the way they do things now, my package is in a container with other packages for Monday delivery, and they won’t even open the container until it is ready to be sorted for delivery.

Couldn’t argue with that. Too bad, though, I would have liked to try the new board over the weekend.

The 5’ cable should be fine, IIRC the SO3’s shipped with a 6’ cable. A 20’ USB cable is asking for trouble.

If you are getting disconnects when powering off, are you turning the router off with the switch or using a power strip? If you are not using the switch on a power strip, try it and see if it helps. I ended up running my power thru an E-stop button for the router which helped.

I had one of the first 70 SO3’s, so I am aware of all of the attempted fixes, I grounded my spindle mount to the Z plate, to the X-carriage, tagged both Y rails, back to the power supply, ferrite cores, capacitors, etc.

I had multiple ferrite cores on my power cable, now reduced to one. I am running a v2.3 board and have minimal disconnects. I will note that when I do experience one it is usually after a tool path has completed and I am moving the carriage or removing my stock from the table.

I have also noticed when the ambient air has less humidity, that is when I used to get more frequent disconnects.

I haven’t removed any of my attempted fixes, it is running well now with an occasional disconnect, but I can typically recover using the homing and touchplate.


My shapeoko 3 came with the 2.4d board. I’ve only had one disconnect, the router cord was dangling down the outside of the enclosure next to the usb cord within an inch or so of each other. I moved the cord to hang on the other side of the box and have not had a repeat. Jorge had said that the new board (then the 2.4d) had solved the disconnect problem. I still took the standard precautions when setting up my machine. Separate circuits in conduits from the service box to the shapeoko and another to the router and vacuum. I also dedicated a ground outlet to ground everything except the shapeoko. The vacuum hose has a bare ground wire inside and the new camera (bore scope) runs along the vacuum hose and over the box and to the computer and is also not near the usb cord (camera has a 15 ft cord). I always turned the router down to low before turning off at the router even though I ahd a switch for it I still use the router on off button (why?? haven’t thought). Hope this helps