Ramming into left side of gantry

I’ve had my Shapeoko for about 2 years now and have made quite a few cuts with it, not as many as I should by now (still considering myself a newbie to the cnc world). I’ve recently had to delete an older version of carbide motion from my computer. Upon downloading it again (the newer version), I’m having trouble running the jobs. I design the file the same way I always have on Carbide Create at least to the best of my knowledge and save the G code to use in carbide motion when plugged into the machine. The first time I ran the machine again, it rammed itself into the left side (nowhere near where I just set my xyz zeros). I tried again, the same thing happened. Started looking on the internet and one site said to reset the settings in carbide motion like it was the first time running the machine, so I did that. It still runs into the left side of the gantry. Any ideas as to what I’m doing wrong? I’ll try to attach the file from Carbide Create to this post.

holder.c2d (112 KB)

I’m an idiot. I figured it out. I had the toolpath zero set to the center instead of the lower left.


Where are you setting the zero at?

If at the lower left corner, that doesn’t match the center (specified by the red mark) in your file:

See Job Setup:

Screenshot 2023-03-24 at 2.30.59 PM

and it may help to review:

That was exactly the problem… I sat down and went over each setting and it hit me. Thanks!

The configuration sets jogging limits but gcode is not limited in movement.

It is good to find your own mistakes. I bet you wont do that again. Hard lessons are not quickly forgot.

Bet he and I and you probably will do it again.

I did this the other day. I always use lower left, except for when I don’t. LOL. I try to save my code with a name that included where zero is but I still missed it. Some things are better zero in center or off spoilboard and others not.

We’ve all done that at least once… Ok At least I have…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.