Random Controller Disconnects

I just was about two hours into a job and flipped on a nearby bandsaw and the CNC machine froze and the USB connection had to be reset. Job ruined. I have been seeing this since I bought the machine but it usually happens near the end when I turn off the Dewalt. If I’m not careful turning off the motor switch the USB connections freezes and I have to disconnect/reconnect the controller. Inside of Universal Gcode Sender I get a Java error, something about “cannot set mask on port xxx.” Its like any slight power glitch can just cause things to freeze on the port going to the controller

Anybody seen this? I should I have some kind of filter/surge suppressor on the controller?

Sparkfun Shapeoko Controller on Shapeoko 3D
HP PC running Win10
Universal G-code Platform V2

I never had this issue when running from a laptop on battery. Now that I have a dedicated PC I do see the odd issue when I turn off the Dewalt. Have to restart everything. I do have my PC on a decent filter as well.

Not see it so far from running other items in the shop, but just haven’t gone there yet.

Have a look at this video:

Shapeoko 3 Disconnect Capacitor Install

The problem seems to be not too uncommon and might be easy to fix with an additional capacitor.

Yes but as I mentioned I have a Sparkfun controller. They resell the Carbide machine but with their own controller. I can ask their support (takes days) if the have a solution.

The fix should work similar there. I also have a Stepoko board and the Sparkfun Edition SO3. A 1200uF / 50V electrolytic capacitor soldered to the power input should work similar. I am currently away from my SO3, but from looking at the Sparfun Stepoko’s schematic, I think I would take a multimeter, check if you see the input power of the power supply at the “Vin” screw terminal in the upper right corner of the board. You should measure something between 12V and 30V DC there if you plugin your power supply into the barrel jack connector. If so, screw the capacitor into that terminal with the correct polarity and check. No soldering :slight_smile:

Something like this:

Usually when disconnects suddenly begin to happen it’s due to the brushes on the router wearing down — another possibility is lower humidity and increased static build-up.

See https://www.shapeoko.com/wiki/index.php/Electronics#Recommendations

Is this a general EMC sensitivity of the boards? Or are the power supplies sensitive and the boards just reset due to DC in instabilities? The later could be cured by a cap…

Sometimes it has happened to me, what I do is to place contact cleaner in the ground pole that goes from the router passed through the S3 structure and connected to the ground, giving the opportunity for the load generated by the router’s motor to travel without setbacks Never operate an engine nearby. I always connect far away from the S3 all the engines that I use in order not to lose time or tools.

I was having similar issues. I finally narrowed it down to static discharge.

Saw Dust generates huge amounts of static. The dewalt router is ungrounded so when there is a discharge it wants to take the easiest path. Sound like that path is through your controller.

I have added a ground plug and wire to my dewalt and grounded the router. I have also run a bare cooper wire through the inside of my dust collection hose and grounded one end to the dust collector and the other to the dewalt.

Since doing this I have had zero disconnects.


Based on what you said above I kind of by accident before turning my router off I connected the alligator clip of my touch probe to the router mount, at the hex bolts. Then I turned the router off. Since doing that, 10 or so tool changes, I have not had a disconnect. The one time I didn’t do that, boom… disconnect message.

So like you I am going to ground the router plate and see how that does. My brushes are also showing signs of wear.

Keep on cutting . . .

1 Like

I wounder if you could try a uniterupted power supply unit. I’ve thought about getting one for my machine just to be safe.

It’s my understanding that most (all?) UPSs don’t work well w/ stepper motors or routers — please check before buying.

I’ve been running a Cyber Power 1325va pure sine wave UPS to power my PC, SO3 and SuperPID/router since nearly the beginning of my CNC adventures, about 14 months now (I added the SuperPID later in the adventure, but have had the UPS since almost the start). My vacuum I run straight off the wall, it just draws too many amps. I’ve never had a “disconnect” per se, although a week or so ago Carbide Motion 4 crashed about 3/4 of the way through the job(I mean the Windows program crashed), and I’ve had the issue where CM4 stops doing anything when I manually jog forward/up for a tool change between gcode programs that others have reported (router not running). I’ve actually had a power failure during a job and everything kept running (except for my vacuum), and the clocks in my house reset, haha!!! I’ve also purposely unplugged my machine while running an “air cut” without issue. I’ve read and re-read where motors and UPS don’t play well, but I’ve yet to see the issue with mine. Maybe I’m the lucky one, who knows? The big thing for me is if power dies, everything should die with it, you wouldn’t want your SO3 dragging a bit around without the router spinning, and you don’t want your router spinning in one spot of the SO3 dies and nothing is holding the router in place (friction, fire, bad things). I don’t run any super special USB cable, ferrite cores, none of it, I think my current cable came with my machine? In my old house I had one electrical outlet in my garage that would trip every time I held my head sideways, so I needed to do something if I wanted to play CNC. New house I have 2 dedicated 20 amp garage circuits. During my research for a UPS I remember that “pure sine wave” rather than “simulated” was the way to go, but it’s been awhile so I don’t remember the exact reason, do some research. My experience has been good, I can’t say that it’ll be the same for everyone.


p.s. make sure whatever you use can handle the amperage of whatever you’re powering + some head room. No point of buying a really tiny UPS just to have it shut down due to over loading. Also, I don’t use mine to keep the power running for a long time if I lose power, it’s used as a way to pause my job, shut stuff down, so I can resume once power returns without losing my spot (Yes, I sit next to my machine the whole time it’s running).

1 Like

I had a similar problem and replacing the USB cable helped a lot but the final fix was running a separate ground from something that is physically connected to the X Gantry. It would move with the Y axis while running. I ran the wire directly into a plug and only connected to the ground prong. Plugged that into the same power strip that the machine is plugged into.

I now have upgraded to the XL and have not needed the additional ground any longer…Not sure why other then the gantry is no longer moving.