Rough Y-axis Travel

Shapeoko 3XL w/HDZ, VFD Spindle, and 2.4e controller board . . .

In the middle of a job, during a tool change, there was a “bump” on the X-axis move (cause undetermined) and the x-axis was about 5 mm left of hitting the BitSetter button, destroying a 0.5 mm end mill.

Hit the Stop button and now the Y-axis travel is very rough - almost as if the stepper motor was over-running the belts. If I let it run to the Y limits, it just tries to keep going - it ignores the limit switch (which is working), but it doesn’t sound as bad as a hard crash against the rear - and it doesn’t stop.

Mechanically, everything seems alright. The V-wheels are OK, belts seem OK. Both Y stepper motors are OK.

Tried swapping out controller boards (to a 2.4d) and the problem persists.

What’s going on?

First, check the Y-axis motors and wiring and the connectors — is everything in good condition and secure?

Power down and remove both Y-axis belts and inspect them — set them aside labeled or arranged so that they can be swapped side-for-side and end-for-end when reinstalling.

Are the pulleys securely in place? Put a witness mark on each across the pulley and shaft.

Put a bit of tape on both Y-axis pulleys.

Power up and connect to the machine and initialize — the machine should home the Z-axis as it normally does, then begin moving the X-axis and trying to move the Y-axis — the X-axis should home as it normally does, while the Y-axis motors should turn until they time out.

Power down and reinstall the belts swapped as described above.

Let us know what you find out at

Y-axis motors, wiring and connectors are OK.
Z-axis homes as it normally does, no problem.
Y-axis pulleys seem to be in place - set screws are still lined up with the flat on the axles.
Will try the belt removal / homing exercise in the AM tomorrow.

Thanks, Will.

To add to what @WillAdams suggested I would first power off the Shapeoko and slowly move the X and Y axis from front to back and side to side several times. You may have a bugger on the rails that the v-wheel is hitting and/or the v-wheel has something on it. Also check the adjustment of all 6 of the adjustable v-wheels to make sure they are secure. A loose v-wheel can cause binding.

Remember to move the axis slowly. If you go too fast the stepper motor produces voltage and makes the movement seem rough. Move slowly.

The original belts were fiberglass reinforced. Later they moved to the steel belted belts and has a lot of issues with the teeth looking pulled. Some people get the kevlar belts. Not sure what C3D sells in the maintenance kits now.

It wasn’t the Y-axis after all.

The X-axis motor was chattering so hard, it made the whole machine vibrate. It wasn’t turning - just chattering.

I removed the X-axis motor, set it on the cross beam and ran the machine initialize sequence. Still chattering - would turn back and forth about 2 degrees and not turn consistently in either direction.

Took the X-axis motor off the machine, removed the pulley, took it apart and put it back together again. Now it works as it should - but I don’t trust it.

How do I go about ordering a new stepper motor?

Write in to and we will work out how to handle this.

It sounds to me that the X motor connector was the culprit, and when you reinstalled the motor, you reset the connector pins.

1 Like

Or there’s a nicked wire. Lots of mods on this machine, including air assist and a J-Tech laser. I wouldn’t be surprised if the air tubing wore a spot on the X-axis wiring.

Glad I checked the limit switches after reinstalling the original controller board. The Z-axis one had failed. The sound of a HDZ crash is impressive. Don’t ask me how I know.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.