Router goes off material when starting job

So, i’m brand new to cnc. I have the shapeoko xxl with bitsetter and touch probe.

I tried making a simple letter ’ A" as my first project. I did it in aspire. I made the material size 12" x 11 3/4" and the letter height is 10".

I connect to the machine, initialize, “load tool” sets z axis and then since having issues with probe working or not knowing how i just go to front left corner of wood piece and set zero.

Once I start the job the router goes way off the piece of wood and I have no clue why so i end up just turning everything off.

Can someone look at my file and tell me any issues you see or just give me some advice on what might be the (100 Bytes)

Hi Matthew,

there was something wrong in the generation of the file, it’s almost empty, as if no toolpaths were selected/created.


The only thing this does is going to the zero point (which you should already be at after zeroing) and raising the Z to 12.7mm
If it went “way off the piece” when you started, you may have a problem in the way you set zeroes too?
Can you post the design file (.c2d) you used to generate that g-code ?

1 Like

hmmm, it won’t let me upload it. says that file type is not authorized. it is a crv3d file

My bad, I did not read your initial post through, where you mentioned you use Aspire.
The usual way to upload a type of file that is not supported here is to compress it into a zip file (since zip format is accepted)

However, I don’t have Aspire so I wouldn’t be able to open it anyway.

Did you make sure you have your toolpath selected in the Save toolpaths menu?
Here’s a random example of mine (in VCarve, but the interface should look similar), make sure your toolpath is checked (bottom) and appears in the “toolpaths to be saved” part

oh okay. i think i saved the toolpath. i know someone directed me to install the post processor recently when i couldn’t figure out how to save the toolpath and once i installed the post processors i thought i saved the toolpath. I will try to open the original aspire file back up and make sure I did.

thanks for all your help! I would like to learn how to do things without having to rely on just buying files

Make sure your zero point is set to the lower left corner in Aspire before outputting the gcode file. In virtually all of the Aspire videos, they start with the zero point (XY Datum) in the center of the material to make it easier to center the design in the material block, but you have to remember to change it to the lower left corner when you make your tool paths. This error happened to me recently.

1 Like

I raise my glass to that! It’s definitely more rewarding to be able to create your own content.
Make sure you understand the basics (there are several tutorials on the carbide3D site), and once/if you are willing to deep dive into the Shapeoko world, this might be of interest to you down the line.

1 Like

yes, i set it up that way where the xy datum was front left corner. that is what is confusing me. the material is 12" x 11 3/4? and the letter is 10 inches, so i have no clue why it would go off the material.

I know you asked if i saved the toolpath. I thought I did but went back in and did save the gcode file.

So with carbide motion do i load job the .nc file or just load the gcode file or if I load the .nc file it will load both? i guess i’ll find out. I’m gonna read all that stuff you posted and hopefully afterwards i’ll have a better understanding

.nc is a G-Code file.

Which file extension Vectric Vcarve uses is determined by a setting in the post-processor.

I see. i’m interested to see what it will do now since when i saved the toolpath it saved it as a .gcode file this time

if you upload the gcode file to you can see where it is relative to the starting point etc

In Aspire (at least on my system) when you select a Shapeoko post processor–either the (inch) or (mm) depending on your preference–the default file extension is *.gcode. My version of Aspire came with Shapeoko post processors built in. You said you needed to install post processors, so I wonder what you are actually using when you save your CAM files?

This topic was automatically closed after 30 days. New replies are no longer allowed.