RPM not refreshed in G-code?

I was doing tests today and noticed a bug in CC. May I ask someone to confirm whether they can reproduce this, before I submit this to support ?

  • create a project
  • create any shape, create a contour toolpath, pick any tool/material from the database, make a note of the RPM value, click ok and save the G-code file. Check in the G-code file that RPM is as expected (in the M3 command)
  • go back and edit the toolpath, change RPM to a different value, click ok, save G-code file again. Check the M3 line again in the G-code file: I see the original RPM value there, not the new one. The toolpath window itself does show the right/new RPM value.
  • save the project, re-open it, and just re-save the G-code: this time the RPM value is correctly updated in the G-code.

I tried the beta CC467 and official CC464, on Windows10, same result.
If someone using the Mac version could confirm too that would be great.

This is not a big deal for router users who set the RPM manually anyway (it will still be confusing to see the wrong value in the prompt though), but for spindle/VFD users that’s potentially bad (which is why I am posting this here, in case this turns out to be confirmed).

Thanks

3 Likes

Confirmed.
Same bug/workaround as this:

5 Likes

Thank you. It looks like this is a more general value caching/refreshing issue. I’ll report it then.

5 Likes

I’ll see if we can knock this fix out quickly.

5 Likes

Maybe while you are investigating this bug you can look at the RPM bug in the tool path window of Meshcam V6 onwards.
Cheers
Mike

Grab the latest V8 release at http://www.grzsoftware.com/dl

2 Likes

I may have experienced this bug last night, but with Feedrate.

I was running some tests on DOC and feedrate. My workflow was this;

  • I had a simple line that I created a contour toolpath for
  • I set the DOC and feedrate.
  • Exported the G Code and ran the code in CM
  • If i was happy with what i saw then i would increase the feedrate and try it again.
  • To do this I would then open up the existing toolpath in CC, change the feedrate, save the edited toolpath and export the G Code
  • Rerun the file

I ran from 2000mm/min up to 8000mm/min and saw little to no change. I then ran 10,000mm/min but also changed the plunge and holey moley - the thing took off on me so much quicker than expected. Not even close to the apparent “8000 mm/min” feedrate I had previously done.

I then fiddled around a bit and came the conclusion I didn’t have a clue what was happening and created a new design with multiple lines and assigned them all different DOC and feedrates and ran my test that way.

You post has prompted some more thinking on it though Julien and I think this is a similar issue;

  • When I edited only the feedrate in an existing toolpath - the feedrate did not update in the Gcode

  • However i believe when i changed the plunge AND the feedrate then they would both update

I’m at work so i cant test or replicate this atm - but it would be interesting for someone to try if they have a chance.

Rightio - i couldn’t let it go so installed CC on the work computer…yep, feed rate wont update in the gcode when editing an existing toolpath.

This is the original contour toolpath with 2mm DOC and 2000mm/min feedrate

The edited contour path where i updated the feedrate to 3000mm/min

I could not replicate the part where i thought the feedrate updated if i changed the plunge though. I changed the plunge and the feedrate remained unchanged.

1 Like

Hi @scottybeefs,

Thank you for confirming. I believe this is a more general bug in the way toolpath parameters are being refreshed, so I am not surprised that you may have seen this with feedrate, as I saw with RPM, and Neil and others with start depth.

Now that Rob is on it, in the meantime the workaround is “just” to save and reopen your CC file, and it will be ok.

1 Like

As @neilferreri mentioned, selecting a different operation then back to the desired one seems to refresh/update configurations. I did so with feedrate recently.

It turns out we were not invalidating the cached data when the RPM was updated. This will be fixed in the next beta.

Until then, I guess you could move one of the vectors and then move it back to trigger the data to be updated.

4 Likes