S03 XL, My Y Axis is off by almost ~2.5mm

I have been machine some fairly soft 3/4 inch pine boards and I noticed that my Y axis is cutting short by about 2-3mm every time.

My X axis is accurate to a faction of a mm (even on a 20+ inch long cut. I’ve never really had any issues with my machine so I’m somewhat of a loss as of where to start looking.

Any suggestions would help.

Check the set screws on the stepper pulleys. a little slop would show as a shot cut.


Agree w/ @MikeDhttp://docs.carbide3d.com/article/169-shapeoko-3-how-to-check-the-pulley-set-screws

Also: http://docs.carbide3d.com/article/42-how-to-calibrate-the-machine-for-belt-stretch

1 Like

Thanks @MikeD and @WillAdams

My set-screws checked out ok. I ran the right, triangle test and took some pictures of my results. See them here http://imgur.com/a/dGNYs

This is probably a dumb question but how do I enter this update into Grbl? Is this done through carbide motion? I can do the calculation just wondered how I input it.

Other issue that I figured I might as ask while I have the pictures up. Please look at where the bit starts to cut each square. It seems like it enters too low at the start of each cut.

Any suggestions?

Here is the link to the pictures again http://imgur.com/a/dGNYs

To enter new settings into Grbl:

  • connect to the machine
  • bring up the MDI window
  • bring up the Log window
  • switch back to the MDI window
  • type the desired setting into the MDI window send area and click “Send”



The divots look like deflection — what is your plunge rate and have you adjusted your Z-axis V-wheels? (the note that they don’t need to be adjusted dates back to when the carriage was shipped w/ the spindle plate installed and should be updated).

I don’t think I have adjusted my Z-Axis V-wheels. I remember rotating them so that the wheels were at maximum engagement.

My settings were all the Carbide Create default for “hard wood.” I know that this is a softer wood but I figured it would be a slower/shallower cut and improve accuracy.

Thanks @WillAdams

My Z-Axis V-wheels were very very lose. Some were not even engaged. I tightened them up so there is no slop but the Z-axis still moves freely. It removed 90% of the deflection. I imagine I can get rid of it all by adjusting my plunge rate and/or further adjustment of the z-wheels.

As far as the Y axis adjustment. That worked great. Do I have to enter that every time I do a run or does it save it once entered?

Thanks again for your help!

Grbl settings are stored in EEPROM and stay there until something happens to alter or erase them.