S3 XXL GRBL Error: Serial Port Permission Error etc

i have read this thread on the topic ( GRBL Error: Serial Port: ResourceError )

and i have followed the suggestions from @WillAdams

  1. deinstall / reinstall CM
  2. restart and clear out PRAM

i also
3. tried the usb cable that came with machine and a different one
4. tried to run it using my PC laptop - different error - “Cutter did not respond”

I’ve also unplugged the 611 to rule out power / grounding issue.

this is my 2nd time trying to use the Shapeoko 3. it ran the “Hello World” fine (apart from the slight drop off in the middle).

my mac laptop does not connect, running 10.10.5 screen shots below are from the three error messages i get when trying to connect. the other image shows the systems prefs - my mac sees the S3.

I was really hoping to get some work done with the S3 this weekend. any help would be appreciated.

Update: i was able to connect to my S3, home it and jog using chilipeppr but i’d be lying if i didn’t say that i have no idea how chilipeppr really works and it confuses the heck out of me.

to get chilipeppr to work u have to download a json server from the github double click on it to run it locally and then from the list of ports select the one you want to use. at which point i was able to home the machine etc.

it does suggest that problem is not the board, it’s not my computer - as such - and it is getting CM to talk to the serial port. - but that’s above my pay grade right now. i hope someone can help me with this as i’d really like to mill something tomorrow.

That’s a strange set of errors — does the account which you are using for Carbide Motion allow apps dialout permission?

hmm. i usually get asked when things like that want to talk to things - the question is why did it work on sunday and not now.

and why does the PC report one error and the mac a different one.

also trying to connect with easel failed (predictably) - UGS connected but didn’t seem to want to play - what is the “Command Letter Expected” thing about? both Chilipeppr and UGS kept spitting that out of the console?

Also - Arduino app connected and when i booted the serial monitor it engaged the motors. shrugs.

i guess tomorrow i’ll start building my mostly printed cnc - i planned on using that for the painting machine but maybe it’ll be the production one after all

update i tried reflashing the board to 1.1 and using CM4 to no avail.

i tried resetting the board

UPDATE my feeling at this stage is that board is bad.

It works! It’s my Mac. Yay!

Prior to calling it i tried the updated GRBL firmware with my PC using CM4 and it worked! so the error i was getting last night with my PC was not the same error that i was getting with my Mac and updating the firmware on the board fixed the error with the PC.

I’m still noticing that the PC drops connection during jog routines - but it milled my surface in pink foam just fine. Ok - no onto test with the suckit dust boot and doing a flip mill in pink foam.

hopefully this week i can figure out what’s going on with my mac - but the plan all along was to use the PC anyway so i’m not really that worried about it all for now. :smiley:

post milling with a coat of PVA to seal it up. hard to see but it came out really nice. :sunny:

Probably EMI. Please see: https://www.shapeoko.com/wiki/index.php/Electronics#Recommendations

1 Like

would standoffs on the board between it and the frame help?

i don’t have this issue with the Shapeoko 2 is it because of the chunkier frame?

You wouldn’t want to use standoffs since they would interfere w/ the functioning of the heat sink.

I don’t know what the difference is that causes some boards in some situations to be more sensitive to EMI than others — @Jorge — is there an explanation for this which you could share w/ us layman?

First up - big thank you to Carbide support, esp @Jorge and @WillAdams for bearing with me and helping to troubleshoot the problem.

From what i can tell the main problem is with my Mac laptop - for whatever reason it is creating the Serial Port Permission error. I have tried repairing permissions on the HHD to no effect - so that’s a deeper dive into serial port permissions, or maybe updating my OS or … ?

Coupled with this i tried to use a Dell Inspirion laptop circa 2013 to connect and run the Shapeoko. While it connected it did not run the software properly.

So i had two computers both exhibiting different problems with the same outcome - a Shapeoko that didn’t seem to work. Which led me and, i think, the Carbide support team to assume it was hardware related.

But the faulty logic seems to be that i did not use a third or fourth computer to attempt to connect and run the machine - and rule out that the first two laptops were good or bad.

in a moment of clear headedness i used a Mac laptop circa 2009, installed CM and it worked fine, now i have a mac mini attached to it - it’s milled a job in pink foam - and today i’m going to try to figure out a flip mill operation and also test the full 33 x 33 area.

Whew. i was really starting to lose it for a while.

fingers crossed for the flip milling.

1 Like

For the USB issues on Macs, resetting the PRAM and resetting the SMC have helped on some machines — I believe uninstalling the serial driver for the port which is created by plugging in the Arduino worked on at least one occasion.

1 Like

how do i reset the SMC?

Depends on the Mac model — usually it’s holding down some strange key combination while powering up the machine.

1 Like