S5: Limit Switch error (x) - Homing cycle failed - GRBL Error: Homing Failed, pull off didnt clear - Machine controller restarted unexpectedly and may be in an undefined state

I followed the steps to load defaults and set the machine profiles in Carbide Motion to be a 4x4 system and sent configuration data. Once back to the main screen I clicked initialize machine, the gantry began moving to the back-right of the machine. At that time Carbide motion generated an error that the controller was offline. I closed/opened and began to receive the screen below.

I googled the errors and found a forum thread about updating my firmware. Even after the firmware update, I am unable to open Carbide motion past these two errors.

I am going through the forums and not seeing any other threads that sound similar to this issue.

Depending on when your machine was shipped it may be necessary to re-flash it.


1 Like

dismiss those errors. In the commotion of the first crash, I pushed the power pendant down to turn everything off. With the machine powered back on, I was able to connect to the machine again (boy do I feel like a dummy!) however I am getting the same errors after the first crash.

Machine controller restarted unexpectedly and may be in an undefined state

GRBL Error: Homing Failed, pull off didnt clear

Homing cycle failed

Limit Switch error (x)


I was able to connect and update the firmware after the first crash using the zadig software. I found fix.pdf from Brandon in support in another post. The firmware update process went as expected.

I am now trying to work the errors in reverse order, the Line Switch Error is the first in the series, however I have not found at Line Errors threads for the S5 machine yet.

Please let us know about all this at support@carbide3d.com and we will do our best to assist.

Yessir, already did that. Forums were my plan-b!

I went through all of the wiring/connections, none seemed loose but my errors have gone away and now up and running. I forgot the troubleshooting 101 basics!!

1 Like

I was having similar problem. All of my ball screw motors couplers were loose. The right was so loose that it had actually decoupled a bit and was throwing off the machine’s ability to touch home. The X-axis was loose enough that it couldn’t touch off after reaching home. There seems to be a bunch grit in the X-axis rails. Brand new machine. Have never cut anything but I am buying some weird lube to try to solve this too.

These machines could really, really use parts diagrams and lists so we are all on the same page talking about this stuff.

Not saying this is your issue, but it might be worth a look.

Zach, did you ever find the fix. I am having the exact issue. I did have my machine running a previous time with no issues, but now I am getting what you are describing. Suggestions welcome.

Contact us at support@carbide3d.com and let us know the specifics and we will do our to assist.

My issue was in the group of wires (behind) the right-side cover plate. No matter how neat I tried to fold/tuck/squish the wiring to get the cover plate on, I would get various sensor errors. So far, so good with the cover off.

for the Seinfeld fans

Thank you Zac. I discovered I had a different problem. After trouble shooting a variety of things such as reinitializing, powering down, ect., I brought my gantry all the way to the front and noticed my X axis had some play in it after being turned on. The play wasn’t in the ball screw for the x axis but where the z axis meets the x axis. I tightened up two nuts which were quite loose and no issues. Thank you for your response. And thank you Will for reaching out on an Easter Sunday!

I’ve had the same issue and this solved it. Thanks @Jonathan_Blank !

THANK YOU! Had the same problem with the error codes upon initialization… both of those screws were VERY loose… tightened them, and problem solved…

NOTE: Last night, when running a job, my circles had a “wiggle” at the 3:00 and 9:00 positions, and my angled text was really out of alignment… makes sense now!

1 Like