Seems I have forgotten how to save a gcode

I am trying out the CCPro and have a file created I would like to carve. Carbide Create Build 462.
I have set the parameters selected tool, and viewed the sim and all looks ok. When I click to save gcode the window opens and wants me to select a folder. I double click the folder I normally save too and it opens and is empty. I go ahead and give my file a name at the end of the string, something like /Alice and and click save. Then when I open Carbide Motion and initialize and try to load the saved file, CM will open the proper folder and shows all of my other saves but not the file I just saved. I have tried several variations and the same result. Then I did a system search and there is no such file anywhere…???
Also, sometimes in CC in the toolpaths page there is a " Send to Carbide Motion" but I rarely see that option.
Where do I need to place my save to folder?
Why do I need to add .nc to the end of it when it is already set as a .nc file?
Why does CC not show the files already in there as it used to?


You shouldn’t have to type in the “.nc” manually. What happens when you only type a name without the extension ?

Any chance that you might be saving the file in a directory from CC, and then opening up another directory in CM that has the same name, but would actually be elsewhere on your system ? (i.e. is the full path of that directory identical between what you see in CC save dialog, and what you see in CM load file dialog ?)

the “Send to Carbide Motion” in CC will only be displayed if it sees that you had CM open and connected to the machine, before launching CC.

There is no restriction of where to place your g-code files / directory.

I agree on the shouldn’t have to type .nc, it shows as already being saved as that…but if I dont, it does not save, (or it goes somewhere in computerland that I can’t find).
The file I select to save to is a desktop shortcut to a file in my documents named Carbide.
That is also the file I go to when loading a job.

I will watch to make sure to power up the control module and CM before starting a CC project. That’s a helpful button.

Weird. Are you on Windows or MacOS ?
What if you try to save the g-code file to another directory from CC, and open that other directory from CM ? same problem ?

windows 8.1
I checked procedure on your earlier question.
the path directories match with a difference being, when I save from CC the window opens looking like a throwback from the ms prompt days (lacking the green type)
The window that opens with CM is a nice new style windows 8 type but with the slight difference there all else is the same (path wise).
Just tried your second idea, and no-go. The save from CC is not saving?
This started happening when I first upgraded to 461? I had to go back to 451 and that’s when the saving problems started.
I think when I first installed CC, I had to set it to open emulated as windows vista?

Could it be that you are finding out that CC doesn’t support Windows 8?

Windows 8 is supported:

and will probabably be supported through 10 January 2023:

Things to try here:

  • enabling viewing file extensions (hiding them is a default I’ve never agreed with, and which IME causes more problems than it solves)
  • check your file associations
  • disable any utilities which might be active when working in a file dialog box

I have had the same issue in the past. This is what I found 1. You have to select where you want the file saved or it will be save someplace else by the default on your computer. I Usually save mine to the desk top. Then once I’m done if it’s a file I want to keep I have folders where I can move it to. 2. When you type in the name make sure you hit the space bar afterwards. Other then that it will not add the .nc.


I complete uninstalled and reinstalled CC 462 compatibility set for Windows 8.
same behavior.
Open CC
set size, retract and grid and press OK
go to-Design, created a circle with the text TEST in the circle
go to- Toolpath and select objects, select bit, set .2 depth, set to pocket, sample shows correct.
check simulation, looks good, close sim and click Save GCode
this window opens asking to " Please Choose a File" .

That folder should show all of my previous files but it “appears” empty.
I add /

and click save.
The file should now be in My Desktop/carbide shortcut.
It is not.
I have also tried to save to desktop. it does not.
The desktop / carbide / shortcut is the only association
A system search does not find the file anywhere (complete system search)
This computer is used only for this Shapeoko. No games running, no video feeds running, no twitter or facebook. Just this work area.

preformance wise,

(the wi-fi activities are this writing updating to the site)

Things were working a few days ago, until I did the Pro offer.
a day before that,

Thanks for that bit of information


  • this is some really strange looking open file dialog indeed ! looks like it prints directory path Unix style.
  • anyhow, even if I don’t have the slightest clue why this window looks like that, I think it cannot work with a path like this:


because “Carbide - Shortcut.lnk” is a file, not a directory. It behaves as a directory when using the windows explorer (from your desktop for example) because Windows knows that “mmh, this is a lnk file, let me go to the directory that it points to”.

Can you try (again?) to save to “/c/Users/Mike/Desktop/” only , and check if the g-code file shows up on your desktop ?

Firstly, Thanks for being Helpful.
Yes. I created a folder on the desktop, (suggested earlier by Gonefishing) selected it and saved but it is not there.

also tried,
created a new folder on the desktop and named it carbide projects.
tried to save to that folder and fail, nothing there.
tried ending the name string with a " space" instead of adding .nc, no good.
tried ending the name without the space ,no good
tried several variations (obviously not the Right ones…) no file.
Tried saving directly to the desktop (no folder) and no file…
also as earlier, Before I upgraded to 461? saving and loading files was no problem, fairly simple. The programs went to where they needed to to save or load a file pretty much as a default.
After I went from 451? to 461? is when the strange file window started.
I have also done complete uninstall and reinstall today and no change

Please send in screen grabs of your file dialog boxes and notes on your operating system and version, as well as a list of any 3rd party utilities which you have running to

sent in two parts.
the rest of 20

Look’s Solved ?!?!
After a system restore, I went into the c\ drive and manually deleted everything in the Carbide Create and Carbide Motion program files, then backed out one step and deleted the folders.
Downloaded CC 462 and CM 513 and installed. Restarted computer (actually the CM installer did)
and all is working again…YaY!!!


This topic was automatically closed after 30 days. New replies are no longer allowed.