Set up problems

Have a brand new XXL Pro. Initial set up a few days ago had Homing in front right bit setter. I switched the two Y cables in the control board and it then initialized in the back right corner as normal. I thought I was done. Today I wanted to check the jogging stuff and play with the xyz probe. After I pushed initialize machine I got a probing cycle failed pop-up. I thought it might be because I had probe just sitting on the machine with the magnet attached to it. I put a piece of board on the bed and put the probe on the corner with the magnet hanging free. I pushed initialize again. This time it homed and then came all the way to the front and prompted “Tool Change Required” (I actually had a bit in machine). I pressed resume and the machine went to the home position and the z came down crashing into my board and continued trying until I turned it off. This cycle happened 3 times (I turned the machine off before the crash the other 2 times). I might also add the when I set up my software, it accepted my XXL Pro and Shapeoko Pro designation but does not seem to save it when I push ok. In fact the only thing it is saving in the set up is the mm is saved to read in. It’s Saturday evening so I know I will not get anyone on the phone…please help (BTW: Carbide Motion version 5) Please help…& Thank you, jim

You need to configure the BitSetter per the instructions:

I watched the Bittesetter video in the instructions. The Carbide Motion v5 that uploaded to my computer (Build 536) only has a Run MDI Settings in the upper right hand corner. It does not offer a JOG setting. The machine is still doing everything I described above. Plus, I might add that the version I have is still not saving the settings such as it comes up in the Load Defults as Shapeoko 3XXL instead of the Shapeoko Pro XXL that I keep changing it to. I have also tried to reload the Carbide Motion v5 but not with Uninstall first.

You will not get access to the Jog pane until the machine is successfully initialized.

As noted in the instructions:

  • connect to the machine
  • go to Settings and configure (both Machine and Grbl in recent versions)
  • then initialize the machine at the main screen

Thank you so very much for your kindness in trying to help me Will. Please be patient with this old (beginner). I clicked on Settings and have only two clickable areas under machine settings. The first is next to Travel Dimensions called Load Defaults. Clicking it gives me a choice of machines. I clicked Shapeoko Pro XXL (then ok).

Below that is GRBL. Under that it says machine type Shapeoko, GRBL version 1.1f. Next to this it says in a box Send Configuration Data. Clicking here says select configuration. I click on Shapeoko Pro. Then push ok and it uploads data.
Below this line to the left it says GRBL active input pins and under that it says Y. None of this area is clickable.

I then push the main OK button at the bottom right.

This screen disappears and the Initialize button appears. I push initialize and the machine homes itself. Only a second after homing itself it heads quickly to the tool change position in the front center of the machine and I’m prompted to change bits. I push resume and the machine goes to the home position and the Z goes down till it can’t go any further.

I’ve been through this cycle many times and always with the same results. I most certainly could be wrong but it almost seems as if the machine is not taking the configure orders correctly because I have to reset everything I put in previously with regard to the machine size and type.

Thank you again for helping…

Please disable the BitSetter under Options in the Settings pane — that will allow the machine to complete initialization, then you will be able to configure the BitSetter per the instructions.

(Note that you may need to increase the Y-axis Travel Dimension to get the endmill nicely centered over the button from front–back).

@PastorJ1m Just to add to what @WillAdams is saying I think he’s trying to point out that if you have not set the position of the Bitsetter it’s likely still using the default values X: 0 and Y:0 and when it plunges down into your table (Z) it’s because it’s actually attempting to locate the tip of the bit. Part of the setup for the Bitsetter you need to jog the machine (X and Y) to align the tool and save this in the configuration. Will already shared the Bitsetter doc above so likely once you have that setup you’ll be good to go.

Thank you, thank you, thank you…disabling the BitSetter allowed the machine to initialize. Then I was able to follow the instructions for resetting the BitSetter. I was so concerned that there was a glitch in the program. I’m so grateful to know that “I” was the glitch.

1 Like