Setting XY origin problem

I’m having an issue getting my machine to accept a manual xy start point using Carbide Motion. I need to use a 1/4 inch hole I’ve drilled in my material as my zero. In carbide motion, I zero the xyz coordinates after moving the spindle to this location and save them. Z works properly but x and y are moving to the far right - almost to the edge of the material - and slightly up of where the tool should start to cut.

I know I have to be missing something simple but I’ll be darn’d if I know what it is.

Any help would be appreciated, thanks!

Are you sure the origin in your design is what you are setting in the real world? This sounds like the behavior you get if (for example) you set your origin thinking it is lower left, but in the design file it is set to centre.

If you’re sure they are the same, then I got nothin’.

1 Like

As @mhotchin says make sure the origin on the shapeoko matches the origin set in the Carbide Create software. If you click on the gear in Carbide Create does the origin match? Here you can see the origins that are options. Is that the origin you are trying to use on the actual material? I generally like to set my XY zero to the centre of the board but I know a lot of others use the lower left. If you are trying to zero off something that is not one of these options then it won’t work as expected. If this does not help perhaps you can send the Carbide Create file you are using and a picture of the board along with were you are trying to zero it.

1 Like

Here you go

Also, I should have mentioned that I use Vcarve Pro for my designing and Carbide Motion for Gcode.
After fiddling around a bit more I was finally able to get the proper cut but I had to use negative datum offsets in the Vcarve setup window. It works, but I feel I’m doing something wrong. Why would I have to go through all that when I should be able to simply choose my zero point - the 1/4" hole, and go from there.

I can’t help with that one. I don’t have vcarve. Hopefully someone else can offer. Some insight for you.

Hi @Ken_R,

Have you checked the generated G-code file (generated before using the negative datum) in a G-code viewer ?

When in doubt, it often helps figuring out whether the problem is in the G-code (and therefore in the CAD/CAM project) or in the machine/user workflow (e.g. a zeroing mistake)

I tend to use ncviewer.com. If you upload your g-code file in a viewer like that, you should be able to tell if the zero reference is aligned to the left edge of your cut. If it isn’t, then you know it’s something wrong in the VCarve project setup.

I use VCarve, but not the Pro version. Does it allow you to select a vector in the design as the zero reference? The version I have only allows one to select stock corners and center as the zero reference (and adding a datum offset, as you did…which may be the right way to do it after all if you need you zero to be set elsewhere than the corners/center)

1 Like

Hello Ken,

I think the others might have contributed the answer, even though it is for Carbide Create.

In short, why would the the circle be your origin? The origin is not the first item you draw on the bottom left. Unless explicitly altered, the origin is one of the corners of the workpiece or the centre of the workpiece.

If you haven’t changed this, it’s going to cut the shape is if the circle you’ve zeroed to is the corner of the stock, as in this bad composite image:

In VCarve, look at your stock settings and look at where the red dot is. That’s your origin.

You your try using the offset to see if it will put the zero in your circle. But it would be easier to move your whole design so it looks like this:

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.