Shapeko XXL Error home failed

Hey we just recently got our Shapeoko XXL machine followed all manual steps, got the machine together, squared, leveled etc, and now we’re trying to initialize it and we keep getting homing failed error and couldn’t find limit switch, the router only comes down and makes a grinding noise, can someone please help us get our machine going?

Does your machine have proximity switches or physical switches.
If you open the settings in Carbide Motion you should be able to see the switches register. So you could place something metal below them or press them and get a message saying what switch(s) is/are active.

Proximity switches, and I’ve checked each switch and they are all active.

If you haven’t already, send the machine EDIT and Grbl configuration per:

If that doesn’t address things, let us know at

Meaning they all show as triggered all the time?

No only when I hold metal against them

Do you have the machine configured for the Z-plus? As @WillAdams linked?
The Z should go up first. If it goes down, all the way, it usually means your Z is configured for the older belt drive.

1 Like

we get travel dimensions, but the automatic spindle control registers 0, and when we try to initialize we still get the GRBL homing cycle failed & couldn’t find limit switch error each time

Well, the switch is at the top, so that makes sense.

Can you confirm that you followed all steps in the configuration?

1 Like

No it’s configured for the XXL and i select belt driven, but It just goes down, make a grinding noise and stops and I have to bring it up by

You have a belt driven Z? Springs and all.

Do you have a belt drive? If you have a recent machine it should be a Z-Plus.

1 Like

Yes I repeated the steps numerous times

Yes it is the newer model Z-plus

So select Z-plus instead of belt drive.

1 Like

OK, I will try that to see what happens, thanks

1 Like

Thank you all so much, changed the setting to Z-plus problem solved, now i can get to some fun and exciting projects! Have a Great night! happy happy!!!


For future reference there are 3 types of Z Axis. The original Belt Driven Z, Z-Plus and HDZ.

FYI: In CM 521 the default for an XXL with HDZ for the Z is wrong. The default config for the XXL and HDZ displays 90MM. The correct setting should be 140/150. The symptom is when jogging the Z down it will just stop at a point that is 90MM from the top. No noise, no grinding just stop. It will jog up no problem but will not go any lower. When setting the default change the Z to 140/150 before sending the config and it will work fine. Not sure about the other two type Z axis settings.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.