Shapeoko 2 Stepper motors just vibrate-seems underpowered

Ok so Im trying to fix a Shapeoko 2 for my college as a final project in my CNC class. Somehow the school got it a few years ago the class at the time put it together but never got it working. Since I have experience with 3D printers it turned into my class project.

After allot of troubleshooting it seems GRBL was overwritten or corrupted on the Arduino so I reinstalled 0.9 from their Github using xloader. Im running the Universal Gcode Sender and I’m using the setting as found here. https://wiki.shapeoko.com/index.php/Grbl_Configuration I tried Candle Gcode viewer and got it to connect but it does nothing aside from that. Anyway, for now, I’m just using the UGS for testing.

So I can connect to the Arduino and I can jog the axis stepper motors but they just vibrate is if they are drastically underpowered. Z is disconnected from the screw so it can turn freely and it just buzzes. The other axis is connected but they moved free’ly manually so its not a binding issue. On the UGS I can see the steps counting up or down as I jog the axis but again they just vibrate and dont move at all.

I checked the troubleshooting guide and it might be my computer, Its just a tablet so it may have an underpowered USB. I also have the screwed up mouse control but the PCB’s are all insulated on the router. The entire machine is basically new and has never run a single part but I suppose there could be something wrong with the drivers or power supply. Any sugestion on what next to try would be great. Thanks.

Just buzzing could be wiring, or it might be steps / mm or some other setting.

Please set the defaults per: http://shapeoko.github.io/Docs/software.html and use http://shapeoko.github.io/Docs/electronics.html to check the wiring

The tablet should if undervolted should only affect the reliability of the connection and powering the Arduino side of the controller.

1 Like

Having dealt with stepper motors from version 1 years ago. Something I remember was that on the control board there are potentiometer’s for each axis. There is a sweet spot where you can adjust them so they have enough power to hold/move the stepper motors. You can also overpower them and they will either jump or buzz and not move.
Again, this is from past knowledge of dealing with them from Shapeoko version 1. I don’t remember exactly how to find the correct setting but it wasn’t super hard other then I remember just slowly increasing the potentiometer and trying until it didn’t work and then backing out.
I hope this helps you!

1 Like

Good point.

This was addressed in the SO1 directions: https://wiki.shapeoko.com/index.php/Electronics_(SO1) — not sure what happened with the SO2.

1 Like