Shapeoko 4 cutout enlongated vs dimensionally correct

Recently purchased and assemble Shapeoko 4 Standard. Assembly appears to have gone well however when I ran the first job, (simple star), the cutout on the wood was elongated…or perhaps more correct the “X” dimension was narrower than the “Y”. Wood was fully adhered to table so no movement there. Any suggestions of the cause and perhaps solutions so we can get a dimensionally correct cut?

Appreciate any help…Regards

If the machine is mechanically sound and the wiring is not losing continuity, then you can calibrate the steps/mm for the belts:

Thanks for quick follow-up. The information provided is for a Shapeoko 3 however I have a brand new Shapeoko 4. Is process the same? Also, I question that a brand new machine and corresponding belts would have a “stretch” issue when less then 6 very small jobs have been run. Not making sense to me.
I checked tension on the belts and all three seemingly are of equal tension when trying to lift off railing. Definitely see belt lift of only a couple of mm. I did notice the travel in the x direction is slightly slower then the y though both seem to move freely when using the quick motion jogging. Resistance in the x direction I presume may be the issue…I see no obstructions though question whether the cable management is the source?

Can you tell us how much the elongation was and how you measured it?

3 Likes

Did you send the correct configuration to your machine?

Every machine needs to be calibrated and periodically checked. Defaults are just that. Individual machines may need tweeking.

1 Like


Here is an example of what is happening. This was a cut of a 3" circle. As shown it has not cut symmetrically
-I checked for squareness of the machine…ok
-drive belts are all snug with approx 2 mm lift when checking tension…
-when jogging machine…travel appears free in all directions both manually and to any of the 9 quick points.
-brand new machine with perhaps 7 minutes of run time
-checked for loose screws…none
-Set machine settings for shapeoko 4 Standard …X=445 mm, Y=445 mm Z=95 (default settings
Any suggestions…

Hi Ross,

  • can you upload the gcode file you used for that cut ?
  • if you open Carbide Motion, go to the Settings menu, click the “Show Log” button in the bottom left corner, keep the new window open on the side, then go to the “MDI” tab, and send $$ in the command line there, you should see a list of $xxx values being logged: what’s the value of $100 and $101 ?

This would be caused by:

  • wrong pulleys
  • wrong pitch on belts

(neither of which should be possible)

  • wrong steps/mm in Grbl
  • controller which is not set to the correct micro-stepping

Please let us know about this at support@carbide3d.com and we’ll get it sorted out as quickly as we can.

Circle Test 1.nc (16.4 KB)

value on line 101 =40 and 100 = 40

The G-Code is correct:

and if there’s nothing wrong w/ the belts and pulleys, then it would have to be the controller — is the circle half the width (along X) it should be? Or twice the depth (along Y)?

Halve or double the appropriate $ setting in Grbl to address this until support can work out how to handle this.

the circle X dimension appears to be approximately 1/2 the correct width

This looks like the culprit to me.

on perhaps a related or not topic…
using the default machine settings for shapeoko 4 Standard …X=445 mm, Y=445 mm Z=95 … it seems that only half the width of the work area is being used. This is shown by using the rapid jog. This doesn’t make sense to me…

Try changing $101 to 80 — that should double the number of steps which it takes for a given distance — let us know at support@carbide3d.com and we’ll work out how it should be handled.

How do I go about changing this? New to this… sorry

Go to the MDI and send $101 = 80

Well this isn’t working out too well.

Changed 101- 80 as suggested.
$$
$0=10
$1=255
$2=0
$3=5
$4=0
$5=0
$6=0
$10=255
$11=0.020
$12=0.010
$13=0
$20=0
$21=0
$22=1
$23=0
$24=100.000
$25=2000.000
$26=25
$27=3.000
$30=1000
$31=0
$32=0
$100=40.000
$101=80.000
$102=200.000
$110=10000.000
$111=10000.000
$112=1000.000
$120=500.000
$121=500.000
$122=270.000
$130=845.000
$131=850.000
$132=95.000
ok
N0 G4P0.5
ok
$#
[G54:0.000,0.000,0.000]
[G55:0.000,0.000,0.000]
[G56:0.000,0.000,0.000]
[G57:0.000,0.000,0.000]
[G58:0.000,0.000,0.000]
[G59:0.000,0.000,0.000]
[G28:0.000,0.000,0.000]
[G30:0.000,0.000,0.000]
[G92:0.000,0.000,0.000]
[TLO:0.000]
[PRB:0.000,0.000,0.000:0]
ok
$G
[GC:G0 G54 G17 G21 G90 G94 M5 M9 T0 F0 S0]
ok

I initialized the cnc and it went to normal home position.
I went to JOG to see if there were any issues moving using Rapid Position and yikes… C is now front where roughly S was. S causes dreadful noises and cnc error messages…clearly it thinks S is off the machine bead. Turned off cnc then turn back on…no changes…something is not right
I changed back $101 = 40, re-initalized and went to Jog…things are back to pre-changes.

Also, as mentioned… only using 1/2 the work area using the default machine settings.
Plan B?

I think Will meant to say to change $100 to 80 (double the standard value), such that X is doubled, but Y remains unchanged ($100 is for X, $101 is for Y)

1 Like

My apologies, as @Julien noted, off-by-one error.

$100 = 80
$101 = 40

should get things back on track.

Please write in to support@carbide3d.com