Shapeoko 5 - Fusion360 - Circles with flat edges with 2d contour

Hey everyone, I’m starting out my first project with the Shapeoko 5, which is a simple, circular box which I’m cutting out of walnut. However on my first attempt, the 2d contour to cut out the final shape turned out to be not circular (at all). I tried just doing a 2d contour around the 4" outline of the model, and I get the same result.

Using a 201 flat end mill. I tried adjusting my feeds and speeds to 20,000 rpm 45 in/min with a .1" step down. I’m using Fusion 360 for modeling and generating toolpath. I have a feeling the issue is in the gcode itself. Nothing in the machine suggests it’s skipping steps (And the oblong shape seems too consistent)

GCode is Here: (3.6 KB)

Here is what my toolpath looks like in F360.

Any ideas?

Check the machine mechanically, esp. the DACs and other aspects of the linear motion and ball screws.

If you don’t find anything obvious to address, let us know at

This is a simulation of your G-code. Dark blue means within 0.001", And if I measure any point on the surface it’s within 0.0002". I’d say your toolpath (Gcode) is spot on!

1 Like

What tool is that for previewing the G-code thus?

That’s NX. I made a post & simulator for my HDM


1 Like

Thanks Will! Not sure what a DAC is but maybe I inadvertently figured it out.

I took out my X axis stepper and noticed that the coupling on the threaded rod was loose. I took it off, lined up the little

Thanks for taking the time to run the simulation! I’d agree this looks correct. Found out the issue was mechanical after all.


This topic was automatically closed after 30 days. New replies are no longer allowed.