Shapeoko 5 pro Bitsetter

I’m a bit concerned that the problem lies in the controller with the cold solder joint issue and it hasn’t been fully resolved yet. Cold Solder Joints and a Missing Component

It came from Sterling, Illinois. I don’t quite know what to think as that letter goes back to September 24th. Thanks for the info. I’m looking forward to what happens this coming week.

Yeah, I just checked, that’s where mine came from. The machine and the replacement parts. Same here, hoping they get it resolved.

My replacement also shipped from Sterling, Illinois. I am thinking the problem is still plagueing new 5 Pro owners. So far for me, this has been 2 bitsetter replacements, a fried front panel board, and apparently also killed my bitzero. Hopefully they get everything worked out.

My VFD spindle should arrive this week, so hopefully I also do not have that issue too.

Hey Thomas,

I’m hoping to get a response from support today (and the rest of us). Did you see the link to a report
posted by Rob from Carbide 3D that Terry, here in this discussion, yesterday? Overall, it sounds like
the Pro 5 had really been plagued. I’m not entirely blaming Carbide3D, but it sounds like they need better ongoing and consistent vetting of suppliers and QC. I know they are most likely stressed to the max over this and will do everything they can to resolve matters, but it’s costing them a lot of added expense and possible loss of sales from new potential owners looking to invest in their machines…


BTW, I also have the VFD spindle arriving this week. I’m concerned about it being a whole new problem too, given some of the recent history of problems folks are having with it…

Right now, I am running the VFD spindle I had from my previous CNC (Have to manually control it). I am also worried after reading that cold solder joint issue might affect the new VFD spindle.

I am beginning to wonder if I caused the issue I am having myself. We plugged the BitSetter into the front port (where the BitZero was supposed to go) instead of the one just to the left of it on the inside right corner. They have the same exact connector. Support indicated that the BitSetter goes on the inside port (shows it that way in the manual also, ugh) and the BitZero goes on the outside port.

I did retry with it plugged into the correct port, but same issue.


Hey Kevin,

Thanks for the input.

I followed the installation instructions explicitly and it was obvious to me where the Bitsetter should be plugged in, so that wasn’t the problem here. Having others responding to this thread and their responses
makes it obvious to me that Caribide3d had a problem with a batch(s) of machines/components of the Shapeoko Pro 5. See earlier responses in this thread. Still waiting to here back from support on latest troubleshooting measure that I and others are trying.

Stat tuned for further developments…

1 Like

I plugged everything in correctly, but when I first plugged in my bitzero and tried to run a corner xyz probe, it did the four corners, and then a poof of smoke from that front control board. Fried the board, and the bitzero.

I definitely think there was some batching issues that are ongoing. I trust that they will get figured out. The machine otherwise is quite solid in performance.

Hey Thomas,

I’ll be t that was exciting!!!

Anyway, I love my machine as well. Aside from the current Bitsetter problem, I’m impressed with overall quality of build and how its functioned for me on some test pieces. If the Bitsetter issue is resolved before too long and installation of my, soon to arrive, VFD spindle goes without issues I will be very happy with my 5 Pro. Hang in there my friend!

Interesting, my wife also said she thought she smelled some smoke when they were both plugged in but they both were lighting up as expected. Pressing the BitSetter caused the green light to come on, and the BitZero lights were on and green and then turned red when the magnet touched it.

I wonder if my board is fried, and maybe the other pieces too?

Told support I plugged them in wrong in an email and am also awaiting info from them.

Also patiently awaiting the delivery of my VFD, hopefully Wednesday. Hope we can get the rest fixed before then.

Keep us updated when they get back to you.

I’ll second that! Just finished a small project and machine worked fine. It took 35 minutes and turned out well. Have not heard back from support yet, maybe tomorrow??

I heard back from support this morning, said they are sending out more parts related to the bitsetter issue. In my case it’s really confusing as my bitsetter worked fine for the first three or four days, then just quit. Curious what parts they will be sending.


Glad you heard from them. As far as for me…notta!!. I sent email Saturday to let them know I received the the replacement controller and it did not (as in your case also) solve the problem.
So still waiting for a response. Thanks for the update. If I don’t hear from them by tomorrow noon, I’ll be
sending them a “what’s up doc” email.


I’m sure you’ll hear something soon. They did say they were short handed today and were trying to catch up from the weekend.

Your ticket was assigned to a person who had the day off.

We will be certain to have someone contact you tomorrow.

1 Like

Sounds good! Thanks for the follow up