Shapeoko 5 pro Bitsetter

Another Newby with a problem.

Just received my Shapeoko 5 pro.

Initial setup went smoothly and i even ran a test piece. I have now been trying to setup Bitsetter and have run into troubles. I went completely thru the setup, as per the written instructions I downloaded, and after entering finish, I re-initialize the program and the machine returns correctly to the home position (right rear) pauses for a couple seconds then returns to the front correct y coordinate, but only moves the z about 4 inches to the left (instead of the middle?), stops and requests a tool change (ok so far). When I enter continue, head moves right to correct y coordinate over the bit setter then only plunges about an inch in z and stops. I’m getting a

“Grbl alarm 4.
Probe fail. The probe is not in the expected initial state before starting cycle.”

I’m also showing a constant input in carbide motion when Bitsetter is plugged in.

Went thru some trouble shooting checks and also found that the LEFT rear limit switch will light up when tested but showing no input indication in Carbide Mortion.

I’ve been trying to work with support (3 different persons) and still jumping through a bunch of hoops.

Thanks for any advice.

My bitsetter had a habit of sticking. If you tap on the bitsetter, does the indicator turn off? Can you push it down & lift it up? Can you take it apart to make sure it’s clean?

I think they moved the toolchange position for S5 closer to the bitsetter, rather than front center. So that part I think is OK.

1 Like

HI Tod,

The Bitsetter must be definitely bad? When i unplug it from the machine the constant input in Carbide Motion goes away. The Bitsetter for the Pro 5 has 2 lights. A red one that is always on and a green one that comes on when the button is depressed and mine is fine in that regards. I took it apart to see if anything obvious but no joy. Anyway, still working with Support staff and it sounds like I’ll be getting some new parts.
Thanks again for responding.

You might want to check the wiring to see if it got pinched during assembly.

Hi Steve,

That was the first thing I did and also did some continuity checking of wires and connectors.

Just finished up email exchange with Support and sounds like they are sending replacement bitsetter.
Also, the fix for the y right rail limit switch was to download the latest beta version of Carbide Motion and it is now responding as expected.

Thanks for your interest and input.

Check to verify the bit zero magnetic end is not touching the bit zero base plate.

I had an issue with that on my SO3, and it would throw out an error code.

1 Like

Thanks for feedback. I think the Bitsetter used with the pro 5 is entirely different than other models. After numerous tests, support is sending me some replacement part(s)

1 Like

I have the exact same problem. Support sent out a new controller and a new bit setter, no joy. When I connect to the cutter and go to the input state in the debug menu the bitsetter light is on even after changing out the parts. I have a feeling it’s in the front plate circuit board. Waiting to hear back from support.

Hi Terry,

Well ain’t that the poops!! I am receiving a new controller today as well…guess I’ll find out for myself where that goes??? Have they said what their next option to resolve is yet??


Waiting to hear back from support, being Veterans day I doubt it won’t be before Monday. Hoping they can get it straightened out. I’m leaning towards the front plate board having a cold solder joint. We’ll see.

OK Terry.
I’ll let you know if I encounter the same results when mine gets here. BTW, did you also have a no Y2 limit switch inpit showing? I upgraded to Beta 622 version and that took care of it.

1 Like

I have the exact same issue. I already received the new bitsetter, but it also shows always active if I hook it up to the Y proximity switch. I am awaiting arrival of the new front panel, since mine went up in a puff of smoke the first time I connected the bitzero to it, and tried to do a xyz probe.

I should get the new front panel today, and hopefully that will correct the issue.

Hey Thomas,

Sounds like the new controller i have coming is not the fix. Keep us posted.

No problems with the Y2 Limit switch here. The machine was working perfectly for the first 3 or 4 days, I started a recent job and it gave me a GRBL not found about half way through the first tool. Ever since then the bitsetter stopped working and I’ve had to manually set the Z for every tool change.

Hi Terry,
Got the new controller, same result as you. I’ve also contacted support and will
probably hear from them about the same time as you. Wonder if
we will get the same response from them??


I received the new front panel control board and extension cable, installed them and still have the same result, even with a new bitsetter. The new front panel control board did not correct the problem, and I think my bitzero was also fried when the first board burned up.

I just reached out to support again to see what’s next.

Sheeesh! I can hardly wait to see where I’m headed…???

I am having the exact same issue. Just setup the new machine this weekend and get the same GRBL Alarm 4 message.

Hey Kevin,

Join the club! It will be interesting to see what support tells you when you reach out. I’m sure they’ll get it sorted out eventually. I guess we all are experiencing a common glitch with current run of the Shsoeoko 5 pro. Let us know how they respond to you.

Curious as to where your replacement controller shipped from, was it Chicago by any chance? They obviously know about the problem, here’s a link to their explanation. Cold Solder Joints and a Missing Component