Shapeoko 5 Stop button causes machine controller undefined state

I have contacted support about this issue waiting on a response, but just curious if anyone else has seen this issue or knows a quick fix?

So it seems anything to do with this stop button in Carbide Motion or the physical button (not the emergency stop) causes all kinds of chaos.

I was cutting something out and hit the stop button as I saw my workpiece holding screw was kind of lose (nothing happened) was just going to stop the machine screw it down and start over if I had to.

Well since I did that, the system errored with weird unknown state errors. I tried to initialize the machine again and now I’m stuck, the system won’t even initialize any more and throws “Machine controller restarted unexpectedly and may be in an undefined state”, “GRBL Error: Homing Failing, pull off didn’t clear”, “Home Cycle Failed”.

Basically you connect to it, hit initialize and moves to the back right corner and then stops and fails with the errors I mentioned above. Won’t do anything else.

Any suggestions?

Shapeoko Homing Cycle Failed
](Shapeoko Homing Cycle Failed - YouTube)

Did you power off? 20 characters.

I am currently working through the same issue. I am letting the machine sit off for a little while, and reinstalled motion on my computer. Mine throws an error right after the z axis moves up.

I’m not sure what “20 characters” means.

Support ended up getting back with me. They got me to check the screws connecting the coupling of the x y and z motors to the ball screws and then the other end of the ball screws.

They were loose, after tightening it initialized correctly.

All of mine are tight, did they recommend anything else?

They sent a PDF with this instructions on what to tighten but that was it. They said if that didn’t work to get back with them.

I assume you sent your machine configuration?

The forum insists that every post has at least “20 characters”, so we all must comply and be ass-imilated! :smiley:


Yes! I have had this issue as well. Same situation as you. I was cutting, and something didn’t look right so I hit the STOP switch because it was closer than my computer, and have had the same message for two days now.

I emailed and called carbide3d, and I have not gotten a response yet.

Tighten up all the ball screw joints and connectors. I posted a video here of what was loose.

All the couplers and the other end screws. Make sure they are are tight. That fixed it for me.

1 Like

I do not a 5 or this problem but there is a big question left out.

How does hitting STOP loosen any screws?

It doesn’t, but mine was brand new. I guess they weren’t tightened up from factory and in the process of using it some it loosened up enough to cause the machine to not be able to initialize. At least that was my scenario.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.