Shapeoko can't do ramp on curve?

I wanted to try my hand at a heart shaped jewelry box so I followed John Clark’s direction, got some nice walnut ready and started making chips. All went great – until – it didn’t. The top and bottom lips and pockets worked great. The profile cutout – didn’t. For some reason the cut ramp just went straight instead of following the curve and as you can see, it did it on every cut depth and as you can see the preview certainly doesn’t show this.

I’m using VCarve Pro 10.5 with the Shapeoko (mm) post processor since this was just a single 1/4" bit. My preview image shows nice smooth sides with no straight lines but the reality was very different as you can see in the attached. I don’t know if this is a bug in 10.5 or if something else happened, but I’m attaching pics and the gcode file so hopefully someone with gcode smarts (certainly not me) can explain what went wrong.

Heart Box 11 inch .25 em.gcode.zip (380.4 KB)

Any insight would be greatly appreciated
Stan

Ouch.
The “let’s cut straight into the piece” linear ramps are there in the G-code, for example that part at the tip of the heart:

If you can share the VCarve file I can try and have a look whether I get the same G-code if I regenerate the file

1 Like

Oh, also just saw this:

Maaaaaybe they released 10.5 a bit too fast

2 Likes

Wouldn’t it be more productive to put this question to the support at Vectric on their forum? They’ve been fielding questions/solutions on several problems.

2 Likes

Now that I know this is a software error and not a Stan error I’m going to. I just didn’t want to go there until I knew.

Great, a nice piece of 5/4 walnut just became custom carved firewood. I do enough of that quite well on my own, thank you. I certainly don’t need buggy software helping me make more. Oh well.

1 Like

At least next winter you will be warm. Today it was over 100 F (38C) so I dont want any fires right now, I am plenty warm.

1 Like

Your fire will thank you for the high quality / good looking firewood :sunglasses:

1 Like

Julien, attached is my CRV for this box. Based on other things I’ve read it sure seems like a bug in 10.5.

Heart Box.zip (887.4 KB)

Well,

I confirmed that they botched the update to the “Shapeoko” post processor, and this is the reason for your problem.

I download your crv file, and regenerated the toolpath, using their “Shapeoko_mm” stock post-processor, and replicated the issue you see in the cut:

But then I switched back to Neil’s Shapeoko post for VCarve, and the same toolpath resulted in this:

with correct ramp moves.

=> the easy workaround for now (-cough-, I mean…long term solution) is to install Neil’s PP: https://github.com/neilferreri/V-Carve-PPs/tree/master/GRBL%20Toolchange

3 Likes

Thanks much, Julien!! I have posted my issue on the Vectric forum, though I should look to see if there’s a Vectric direct issue reporter. The only reason I didn’t use @neilferreri 's is because it was a single tool. I usually switch depending on my tool usage. Does Neil’s work ok with just one tool? If it does I’ll just use that all the time.

it does, or maybe I don’t get what limitation you are referring to ? A long time ago (pre-BitSetter era) I think at some point it did not support multi-tool jobs, but the latest and greatest version does everything you might need to work on a Shapeoko, BitSetter included.

For some reason I was thinking that it was ONLY for multi tool jobs and that I HAD to use the standard PP for single tool jobs. But since it works in all situations I’ll just use that from now on - thanks!

3 Likes

@ctdodge You have a reply and question and suggestion at the Vectric forum.

Why did you uncheck the ramp lead in box and add 2.0" distance?
I seldom use ramps but I have found that if you leave the lead in box checked the machine will lead in following the vector selected.
Of course when I change it to 2.0" in the program the simulation shows that it too follows the vector profile. Maybe it is a bug!Would it be possible for you to post your .crv file for review?
Sharkcutup

1 Like

Regarding this problem, Vectric has a new update patch 10.504 that is supposed to address the situation.

3 Likes

There’s been a report that the ramp on curve situation was fixed in a new PP.

Loonster Tue Jul 14, 2020 12:10 pm
Got the revised post processor file for GRBL this morning. Fantastic over-night support response! Ramping on a curve works OK now. Many thanks.

Message from our forum
No more than 3 consecutive replies are allowed. Please edit your previous reply, or wait for someone to reply to you. There’s always another rule!

The message I was trying to post next follows:

More information on the change to the post processors on Vectric forum.

Both mm and inch versions of Grbl post processor were updated. Both should now have the following section:

Code:

begin PLUNGE_MOVE

"G1[X][Y][Z][F]"
3 Likes