Shapeoko moving twice as far with carbide motion

Ran into a strange problem with my shapeoko 3 (which I bought in January 2015) where I created a simple square 1" x 1" x 0.1" in Carbide Create and using Carbide Motion it cut a 2" x 2" x 0.2" on wood. I’m using Carbide Create build 313 with Motion v3 build 368. The dip switches are for 1/4 step (using NEMA 23 motors) and $100-$102 set to 40.
Using MDI in Carbide Motion, when I type y25.4 it moves 2 inches instead of 1 in.

Did something change in the new releases?


edit: Will below is far more helpful…
Funky… Using CM v3 - you’re not using grbl 1.1 are you? Do you get the same behavior on the same gcode with a different gcode sender? (grblpanel for instance)

Yes. For 1/4 step the correct number of steps / mm is 20, and in the new release one is supposed to have them to 1/8 — please power down and set them to 1/8.


Yes, setting to 1/8 step fixed the issue!

Looks like there were some other advancements while I was inactive- like homing switches which will allow me to upgrade to grbl 1.1 and the shapeoko upgrade z-axis plate. If there’s any other changes, let me know as I’m putting my cart together now.


1 Like

Big upgrades:

If you have EMI issues, you may want to consider getting a new board (and keeping the old as a spare) — send in an e-mail to for the purchase link.

Thanks! Will email - one symptom I’ve noticed is that if I turn off my Dewalt router, the CNC reboots itself. Fortunately, it doesn’t happen when I power it on or while running. I presume this is due to EMI?


Correct, that’s caused by EMI. One thing you can try is to turn the Dewalt down to 1 before turning it on/off.

Also can try routing the power cord as far away from any other wiring as possible. Mine goes out the right hand side of my machine, opposite the stepper wiring. I haven’t tried this, but others here have tried and been successful in adding a 3 wire power cord to the Dewalt. Extra wire (ground) goes to the Dewalt case.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.