Shapeoko Pro Bit Setter Issue

I am having an issue getting the bit setter to work.

I went through the setup several times and its still not working, here’s what is happening

Power on machine and initialize

Gantry moves to back right of machine and homes correctly.

Then gantry moves to front center of machine and I get a message “Please Insert Tool”

I then click on “Resume”

Gantry moves over the bit setter, moves down maybe an inch and stops.

I get a message “Probing Cycle Failed”

Is your BitSetter red LED already active while the movement downward to the BitSetter starts ?

1 Like

No, the LED is not red unless i push the button on the bit setter

Ok, next check would be to go in CM, Settings menu, and check if you see the “Probe” condition being triggered even though the BitSetter is not pushed?

Do you have a BitZero also plugged in ?

I dont have a bit Zero

I dont see “Probe Condition”. Where would that be at?

Ok.

So if you go in CM Settings menu, what does the “GRBL Active Inputs Pins” line show, before and during the BitSetter probing ?

Your screens look a little different than mine but heres what i see

1 Like

Yes sorry I used an older screenshot.

So, your first pic shows that the controller sees the BitSetter as permanently activated (see the “PROBE” line under GRBL Active Input pins), when it’s not.

It is likely that there is a wiring issue somewhere between the BitSetter and the controller.

Try and double-check where/how things are connected ?

You can contact support@carbide3d.com to help you figure it out too.

The normal situation would be to see “No active pins” in that screen by default, and to see “PROBE” only when the BitSetter button is pushed

1 Like

If i deactivate the touch probe it still says “Probe” under Active Input Pins.
If i unplug the touch probe at the controller then it says “None”

Looks like maybe the cables are switched in the connector on the plate side

2 Likes

I agree this looks like a miswired connector on the plate side, and it would explain what you are seeing, but I have no first-hand info on the specifics of the Pro wiring, so it would be better if support could confirm (or maybe at least someone else who owns a Pro)

1 Like

I agree. I’m just not sure if its the connector on the cable from the controller or the connector on the cable from the bit setter switch thats mis wired

Does anyone have a shapeoko pro that they can send me a picture of the cable connections for the touch probe on the plate end. I have a wiring issue and im not sure if the mis connection is on the cable from the controller board or the connector coming from the touch probe.

Ground is typically black. If that convention is being followed, it looks like the cable connected to the board is wrong - another forum post has the GND pin on the opposite side of the X Y Z sockets.

Not sure if this will help, but I was asking someone for some remote troubleshooting of my Shapeoko Pro XXL and tried to document all the cables and wires by the control board

Not a fancy video, just trying to be practical

Thanks everyone. I was able to reverse the connector behind the plate where the probe plugs into the cable from the controller. Now the bit setter works.

2 Likes

Is there any qc done on these before sending out? Or is the qc person out with covid. Seems like a lot of simple mistakes in wiring with the pro’s Or missing parts. Kinda glad I didn’t get one yet.

1 Like

I totally agree. Simple mistakes but they sometimes take hours to find the issue. Including back and forth with the support team. Thank goodness for everyone posting their issues here. That’s a big help.

1 Like