Shapeoko pro bitsetter crashes

I just got a new Shapeoko pro XXL and I’ve been trying to get everything initialized but I’m having trouble with the Z axis. When it leaves the home position it goes to the front center prompts a bit changes, it then goes to the bit setter centers starts down and never stops until router is pushed up and Z drive crashes. I have gone through about everything I and youtube can come up with with same results. I’ve checked the wiring, all connectors, and verified every step results always the same, any suggestions.

Be sure you set your configuration with the correct Z axis. I think the Pro only ships with the Z-plus. When you power on you can push your BitSetter button down and a red light should come on. If the red light does not come on it is not working and the signal to stop the Z is never received.

To set your config power on the Shapeoko Pro. Connect but do not initialize. Go to Settings and set your configuration and your Z type. Go to the second tab and unclick the BitSetter. Go back to the first tab and send your configuration. You get a confirmation with a fuel bar for sending, it only takes a few seconds. Then initialize and bring your router to the front center with jogging or the rapid positions. Then job over to the BitSetter and set the position centered on the bit setter with the bit close in the Z position and centered on X and Y. Go back to the Settings and set your config again. Go to the second tab and set BitSetter and with the router still over the BitSetter use the current position to set your BitSetter location. Go back to the first tab and send your config again.

Just make sure your BitSetter lights up red when you push the button manually. If it does not turn red then troubleshoot your connections on the controller.

I’ve done all these things several times, the red led never lights up. I’ve checked all the connections several times, everything is connected but since the led never lights there must be some other issue. The pro does not have a Z selection on any tabs so I cannot choose, it’s chosen for me

Can you get a picture of the connector at the board?
Could have wires switched.


Here is the photo you requested

As Neil suggested you are wired improperly or you just have a bad BitSetter. Talk to support for a replacement. You can still use the paper method to set Z in the meantime. Uncheck BitSetter to avoid Z crash.

Based on other pics around here, that connector looks to be on the correct order.
Any chance anything is loose?

No, it’s been checked from one end to the other several times.

If you haven’t already, get in touch with support@carbide3d.com, it may be a faulty BitSetter.

1 Like