Shapeoko Pro - something just ain't right!

Finally had time here at work to assemble the Pro. Followed all instructions, and I’m finding, when I try to cut a test, that it either tries to go past the limits (grinding, naturally), or tries to cut up in the air. I have re-initialized this thing 3x now, followed the instructions, every step of the way, and something is STILL screwed-up. I’m no genius here, but the instructions state to select the settings for XXL in a couple places, but I have a STANDARD Pro, and it looks like all of the various default settings are off for the travel distance of my machine. I’ve checked to ensure all the limit switches are good, and when I initialize and set the Bitsetter, no problems. When I try to cut something, it acts as if it is trying to cut on a larger machine, moving the starting point twice as far from where I’m expecting it to start!

Let me just get off my chest that I am disturbed by the fact that there are no actual setting selections for the Pro Standard In Motion and Create, because, well, it just pisses me off! Why am I doing this for a Pro Standard?:

“In the Set X/Y Travel popup window that opens, select Shapeoko Pro XXL from the
dropdown list and click OK.”

When I do this, then move into the Bitsetter part and set zero, clear offsets, and then rapid jog to the SE position, it hits the end cap and grinds! It doesn’t do that IF I select the Pro XL instead of XXL, so that’s the first issue I have with the instructions! Shapeoko XL it is then!

Same goes for Create. No option for the Pro Standard, so I select the XL, zero it to the top of the stock I’m using (1/4" MDF), do a simple circle to cut to a depth of .18", save the gcode, and it just doesn’t work. It’s as if it ignores all of my settings, and it drives past even the limit switches! I’m killing my stepper motors and belts here!

There are many more issues, but I’m just too frustrated right now for a Friday afternoon.

Any assistance would be appreciated.

You should be able to adjust the Travel Dimensions to match those of the machine, see:

Machine selection in Carbide Create has no affect on anything in current versions and is simply an artifact of earlier versions which would calculate feeds and speeds and limit stock size.

For setting zero relative to stock please see:

Have you tried doing one of the tutorials?

Please post a .c2d file, generated G-Code, step-by-step notes on how you are securing your stock and setting zero relative to it and managing all tool changes an a photo showing an attempt at cutting still in place on the machine and we will do our best to sort things out with you.

It looks to me you’re leading the OP astray here, @WillAdams.

Isn’t the issue with the configuration of the software, at this stage? If @cpangracs has the Pro, I’m assuming it must be a 4, then shouldn’t the configuration within CM should be set specifically to the STD PRO from the dropdown, first?

Also, it might be worth taking a look at the online guide for CM, because it’s a tad out of date.

1 Like

Configuring the newer versions of Carbide Motion is covered at:

That’s all fine and good, but I have no idea of the correct travel dimensions of the Pro Standard, and there is nothing I can find stating the exact measurements. If they are the same as some other printer in the Shapeoko line, fine, but there is NOTHING stating that in the instructions, and there is no selection for these defaults in any of the software which, to me, is a complete fail on the part of Carbide3D. An utter and complete fail. This is an almost $3000 machine that has crappy, incorrect instructions, and it is unacceptable.

What I want are the EXACT instructions on how to correctly initialize the software used to drive the machine, and the exact procedure to get said machine to cut correctly. I have little confidence in any company today that reuses instructions or procedures meant for a different machine OR uses a single set of instructions for multiple machines WITHOUT specific notations for different machines in that line.

As a consumer, having correct instructions and direct contact from the manufacturer on changes implemented in software or firmware is just basic customer support.

As it stands right now, I can neither recommend this machine or this company to anyone, and the US Government may soon be requiring Carbide3d.com to come and take this machine with incomplete support documentation and give the taxpayer their money back…

EXACTLY! The Pro has been out for quite awhile now, and you would thing there would be updated and CORRECT information on how it is setup. Why am I being forced to scramble for the most basic information to get this thing operational. It’s ridiculous! I’ve built my own 3D printers from scratch easier than this “consumer-level” product. To say I have little confidence in Carbide3D is an understatement. Yes, I’m frustrated, but that frustration is warranted.

1 Like

OK, thank you. Searching in Google I found this, so is the “docs” area now redundant?

My understanding is these settings are added by the program once the correct device has been selected in the drop-down list in Carbide Motion (CM) when clicking the ‘Send Configuration Data’ in the first screenshot of @WillAdams link above, and then ‘sent’ to the machine. Are you saying the Pro Std is not listed in that drop-down? I can’t check because I’ve uninstalled the software, sorry.

That is correct - there are NO settings from any dropdowns for the Pro Standard. I am going to enter my own calculations and go from there. At least it “shouldn’t” try to destroy itself in the process.

1 Like

Well, I was wrong. After entering what I believe to be “safe” travel dimensions (440x, 440y), and after setting the zero for the job, the head STILL moves only to halfway to the front center (at about -220x, -440y), then, when the job starts, the head moves as if the job is a mile away. I have to shut down the machine before it hits the X limit and starts grinding.

Look, I’m no genius, but I have built 3D printers for years, so I understand how x/y/z works (or supposed to work). The limit switches ARE working, at least mechanically, because I CAN home all when initializing the machine, The bitsetting routine also works just fine.

I run through setting the zero for the job, but what I described above keeps happening. I’ll try it all again in a video soon and post a link or something to try and explain what is happening.

Reference Carbide Motion, I will state again, there is no selection for the Pro Standard, so, there is nothing matching my machine’s travel dimensions available. How can this be? How am I the only person having issues with this? The travel dimensions to select from aren’t even close to correct. Selecting the Pro XXL, AS PER THE INSTRUCTIONS, does NOT work, no matter what.

What it seems like to me is that there is some math not working out here. I certainly cannot be the only person facing this challenge, UNLESS, I am the only person silly enough to order the Pro Standard?

1 Like

Hi Curt,
Please give C3D a chance to get this figured out with you, they are a great company and go the extra mile for their customers every day. I had a few quirks with my machine, they helped me figure it out and I can not tell you how many amazing projects I have completed since.
Totally worth the effort, good luck!

5 Likes

I might have missed it, but if you haven’t already opened a trouble ticket with C3D I suggest you try that.

1 Like

Email has been sent to support.

1 Like

I’m a fellow PRO Standard owner and ran into the same issue, but the solution is pretty straightforward:

  1. For “Send Configuration Data”, you do need to select Shapeoko PRO.
  2. For Travel Dimensions, you can enter manually, or choose “Load Defaults.” This brings up the dialog that does not include Shapeoko PRO Standard, but since the dimensions are the same as “Shapeoko 3 Standard,” you can just choose that instead.

Winston’s assembly video shows the steps here, but note that he’s working on the larger XXL size: Shapeoko Pro Assembly Overview - YouTube

Note that Shapeoko 4 owners have been choosing the equivalent size Shapeoko 3 choice for a long time now. I agree this should be an easy fix for Carbide3D to address and don’t know why it hasn’t risen up in their to fix queue.

5 Likes

THIS is what I was looking for! This “should” solve my issue! Thanks a million!

I assume I choose the “Z-Plus (lead screw)” option while loading the defaults for the 3 Standard?

1 Like

I got it to “initialize”, finally, but have to add extra travel to reach the bitsetter…

Some folks have stated that sending the configuration multiple times (three was suggested) is necessary in some instances.

Resending the configuration should work — if it doesn’t let us know what you’ve tried at support@carbide3d.com and we’ll do our best to assist.

I have set the bitsetter and run another "initialize, but the head moves to the front-center X when that initialize is complete. When I do a “home” command, it goes to the back-right and grinds. I just don’t get this at all, and to get direct help from Carbide, I have to set-up a time an entire week out!

To schedule a video chat it might be a few days out (those are set up more for training and onboarding) but you can send an email to support with your phone number and ask for a callback later today.

2 Likes