Shapeoko Pro spindle stopping in the middle of the bed for both X and Y axis

Hello all,

I am using a friend’s Shapeoko Pro that has recently moved between different studios, so it’s possible that a limit switch or wire has been tampered with or damaged.

The spindle was in the back right of the machine when I turned on the machine, and when I tried to bring it to the front in order to touch the bitsetter, it stopped in the middle of the path and wouldn’t go all the way forward. I tried moving it all the way to the left on the X axis, and found that it stopped in the middle of the bed as well. The Z axis seems to work totally fine.

I’m a beginner and I’m not sure how to trouble shoot this. I was also not the one who set up this machine. Any detailed tips on which wires to look at would be extremely appreciated. It looks like all of the wires are intact and the machine is pretty free of dust.

Let me know thanks so much!

Run the configuration. When jogging it is limited by the configuration. So if the machine is an xxl and it thinks it is an xl it will not move beyond the limits of an XL. So power on and connect but do not initialize. Go to Settings and run the configuration and be sure to pick your machine and Z and that will likely fix your problem.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.