Shapeoko Pro XXL not working correctly

I’ve been trying to talk to someone in Carbide 3D support and am having no luck. I suspect I’m not the only one having issues.

Here’s the issue: I recieved my machine last Friday and got it built by Monday morning. Except for a few hickups (that were my mistake), it went pretty smoothly. Problem was when I tried to initialize the machine the first time, it was unable to perform the homing process. It tried to home the X axis and when it got to the right side of the machine, it tried to keep going. I had to hit the stop button. Several more attempts resulted in the same. Here is my attempt to troubleshoot…

  1. I checked the wireing to be sure that all the end stop sensors were plugged into the right connector on the controller board: They were!

  2. I held a wrench close to all three (X, Y, and Z) homing sensors to see if they lite up: They did!

  3. In Carbide Motion I went to Settings/Machine and checked the GRBL Active Input Pins and tested each sensor again with a metal wrench and each one showed the input for the proper sensors!

It appears that the homing sensors are working as they should and the motors (X at least) are working as it should, but the controller does not seem to be telling the motors to turn off when the sensor is triggered.

That is the extent of my trouble shooting ability and I really need help to go from here. I’ve tried calling Carbide 3d several times and it always get a recording that they are unable to take my call at this time.
I did get a form email saying that my ticket had been escalated to the next level but having not really talked to anyone, I can’t figure out what that means.

I have about 4k$ into this considering all I bought and it’s really frustrating that I’m not hearing anything other than the one email that did not help me at all.

Can anyone give me an idea of what I can try next?

Addendum: Just noticed that there is a flashing red led in ther lower right corner of the controller board. I don’t know if that is SOP or what.

Sounds like perhaps your homing sensor needs adjustment so it triggers properly when the axis moves to the end.

You’ve already indicated that the sensors appear to work. So when the X-axis homes, the sensor should light up when it reaches the end plate…or close to it. If it’s not, then the sensor needs to be moved slightly to properly pick up the end plate edge.

All three sensor do light up when I put a metal wrench next to them. They also show GRBL input in Carbide Motion.

When it fails to stop the motors, the light on the sensor is on so I assume that its triggered. That makes me think the problem is with the controller…not the sensors.

Your ticket is open and assigned to a tech who will respond once they get to your spot in the queue.

1 Like

I had a similar thing happen when I first got my SO5. It was happening w the Z axis though. There was a little metal dowling that had come loose inside the Z assembly so it wasn’t triggering the limit switches and so it would just keep trying to go up. I’d have to mash the stop button. Once I found that metal dowel and tightened it back in, everything worked fine. I wish I had a more technical term and diagram to give you but I’m guessing you have the same issue. The thing that’s supposed to set off the limit switch is out of position. Good luck.

Thanks. The difference here is that the limit switch is being triggered. I know this because the red light comes on and a X is shown in the GRBL input settings.

Support got with me yesterday and switching cables moved the problem from the X to the Z axis (had something wired wrong), but the problem is now happening on the Z. The Tech seems to think that one of the cables is bad and has ordered another for me. I am very skeptical that this will fix it, but don’t know until we try,

That is quite the weird issue. The fact that the problem moved with the cable swap definitely suggests a bad cable/connector issue.
If the problem was with the controller, then it would not have changed axis. Still just strange that a connector wiring issue results in the stepper not stopping after it is moving in the right direction.

The firmware is pretty solid. If the homing switch is actually triggered, the machine will home (initialize) correctly. That leaves a mechanical problem (not reaching the switch), a bad switch, or a wiring issue.
What did you have wired incorrectly? Did you swap the X and Z motor connection?

For assistance, i have always emailed support and have received replies within a few hours and quicker if its back and forth conversation. Im new as well and i look at the quality of the unit and the potential once i get over the beginning stages to help me through it. Have you tried booking a video call so that on a specific day and time you can have someone help you. I have been writing down all my questions, and booked a video call. Hopefully i retain it all. The process is the fun part, once anythings done we just look at it : )
Hope it all gets working well for you

1 Like

Carbide support did get back to me and he is helping me figure this out. We did a video call because I was having trouble communicating. He has ordered a new cable and a couple other things. They will probably arrive today or tomorrow. I have to admit that I have the patience of a 9 year old some times.

I am greatly impressed with the quality of this machine. They really didn’t skimp on anything. The documentation is great and aside from my impatience, the support is great as well. It took me about three weeks to get the machine, but from the day I ordered until now, I have cut a thousand board feet of wood in my head, so I am very anxious to start making chips.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.