Shapeoko Touch Probe causes Door Open Error

I just updated to CM4 (4.0.410 is the one it just installed) in order to use my new C3D probe. The probe seems to work mechanically (LED is solid green until the clip makes contact with the probe, either directly or via the cutter tip, in which case it turns red as long as the circuit is closed). However, anytime the LED is red, CM4 stops and says Door Open. I know the Door Open is a feature for the Nomads in Europe, but I have a 2015 Shapeoko 3 that I recently converted into an XL.

My Carbide Motion board is 2.4 (not 2.4d or 2.4e, just 2.4 with no reserved header but instead the old fan connector), so I wired the probe using the 2.3 method or red wire to the ICSP’s positive header and the green and white wires into the 9th and 10th pins at the top right of the board. (i.e. With the X Y and Z limit switches in 1,2 3,4, 5,6 and skipping 7,8 which I believe were reserved for an E-Stop).

Please contact — we’d like to swap that board out for a new one for testing purposes. Thanks!

1 Like

Hi mark, could you humor me and connect the probe to the pins next to the Z limit switch? There’s no estop on 2.4 boards regardless of letter version, and I think you might have hooked up to the feedhold. If that’s not it we’ll gladly swap boards like Will said.


That worked! I tried Z height and corner probing a few different times and they worked perfectly once I moved the connector left two pins! (I think the installations guide needs a section added for people who have the 2.4 board but prior to the d/e variant. I assume mine is 2.4a-c, unless I’m the only one who has this board? Possible because I picked it up directly from Apollo when my original board kept disconnecting every time the router was turned on or off.)

Other notes for this board is it was a very tight fit getting the probe pins onto the pins next to the Z-homing pins. The plastic is just slightly bulky so I had to wedge it in there. I almost pulled out the 1x12 header that came with my original C3D homing switch kit). Also worth noting in the guide is that there is a fan connector right where the reserved one appears to be on the 2.4e board and it fits the probe perfectly, but I assume is 12v instead of 5v and might be devastating for the probe to plug it in?

1 Like

I have a 2.4C board and it was a pain to plug into those pins, I unplugged my homing plug then wrestled it back in worrying the whole time that I was gonna either bend a pin or break the pins loose from the board. It’s like the spacing is wrong, like maybe 2mm spacing rather than 2.54…I dunno :man_shrugging:


1 Like

I did the same thing. I removed the Z limit pins in order to get the probe header in and then had to push them both o at once.

Does your board say 2.4c? Mine just says 2.4 so I’m guessing that means it’s 2.4a.

Yes, mine says 2.4C, seems it was a transitional board as it’s not specifically documented in the probe instructions.


1 Like

I have a 2.4 e board, and get same error, using aftermarket probe…

I also have the 2.4e board and am greatly depressed in the response of the PWM and last I read pin 13 was spindle on. Placing these on one connector is more than desired, if they out put actually output the desired response. I have gotten the DOOR OPEN alarm by tapping the the FEED HOLD button.
I have interrogated this board many times with a scope and always come out disappointing.
Is it so hard to pass the S-code through to the controller that controls the spindle?
Even if it’s mapped to a range they think appropriate, i can handle that in post or intermediate board that i’m working on for really custom M-codes… I love this hardware, but I get tired hammering simple stuff to do simple stuff…