Shapoeoko 5 PRO hardware, VFD, and spindle Issues from the start

Hello everyone, I am a long time Shapeoko customer. Currently I own the Shapeoko 3 XXL and now the Shapeoko 5 Pro 4x4. I’m sorry for the long read here ahead of time. I’m just beside myself with this whole situation.

I imagine like everyone that gets a new machine I was extremely excited to set the new Shapeoko 5 up. I started the assembly on a table I had waiting, ready for the machine to arrive.

It was all going great until I went to hook up the y limit switch and noticed the wires were pulled out of the connector right out of the box. No biggie right? They are just connectors and Carbide3d sends a “spare” limit switch so I swapped it out and went on my way.

The machine goes together smoothly, and after the workout of the 80 machine screws to put on the hybrid bed I go to run all the wiring and cable guides. I get to the 3D printed rear cable guides and realize that there is no hardware to actually put those on. No biggie again Carbide3d sends out a bag of “spare” hardware. I find enough bolts in the spare hardware to put one bolt in each temporarily and move on to the mdf.

Well, I get about 80 percent through and finally realize that I’m about 20 bolts short to fasten the MDF onto the aluminum tracks. Back to the spare parts bag and there were only 4 of that size.

I said OK, time to get in contact with customer support because something is clearly wrong. Also noting that none of the hardware was there to actually use the clamps that come with the machine also.

Customer support was friendly, asked if the box was damaged at all in shipment, it comes in 2 boxes inside two boxes with each step also boxed, so it wasn’t a shipping issue. They kindly sent a new “spare” limit switch and the bolts I was missing for the wire guides, mdf bed and clamps. I was like awesome soon the machine will be up and running.

That was last week. Now for this week. I pull the vfd and spindle off of my Shapeoko 3 and move it to the new machine. This is where the real problems started. I opened carbide motion, set all the things needed to set for the vfd, bitsetter and so on and saw the machine move for the first time. I hit RUN on the vfd to test it after the move and it instantly starts spinning at 300rpm. I confused as at that point I had no software running that should be commanding it on. So I grab my multimeter and start probing away. This behavior is not only frustrating, but also dangerous. Imagine having whatever issue the controller is having happen while your mid tool change.

  • EDIT

Here is a video of what it does when hooked up correctly, on power on it turns the spindle on at 300rpm, on initialize is surges then returns to 300rpm. I use Gsender to show what it does and test it as it allows me to use the console and click buttons to turn the spindle on, off and set arbitrary speeds unlike the restrictive carbide motion.


It turns out, that the controller box, on the spindle plug is outputting 0.1 volts the second the machine is on. That explains the spindle spinning without anything running and it being just powered on. I sent an M3 S24000 and measured the output, now it was outputting 2.344 volts. Ok so whats going on here. I checked the settings in GRBL and min speed is 0 and max speed is 24000RPM. Clearly there is something wrong with the controller at this point so today I get in contact with support again.

I want to stress here that I tested these voltages both with the vfd plugged into the controller board and also with it not even being in the picture. There are 3 wires that come out of the connector for the spindle out of the 6 pins. the black one is ground ref, the red one is +24v and the green one is supposed to be 0-5v PWM.

This time they tell me “we don’t support any unauthorized accessories”, and “how do you know that’s what the voltages are supposed to be” and “if you bought our spindle we would have no problem helping you” and “we aren’t going to send you a new controller, that’s not going to happen”. I didn’t even ask for a new controller at that point. I was just explaining to him what the issue was and the diagnostic tests I did.

I don’t have to tell any of you that this is disheartening. I just paid 4000$ for a machine, that came to me with missing parts and a faulty controller board, only to be told I should have paid an extra 700+ dollars for a spindle when I already had a perfectly good one in service.

The spindle runs perfectly in manual mode with the external controls disabled. It even works perfectly when I use my variable dc power supply to give it power between 0-5v. 0v off, 0.1 volts and it spins like it does when its connected to the Shapeoko and at 5v it reads 24000rpm.

It got to the point on the phone call with support where I asked “well then how do I just return the entire machine?”. The response I got was amazing, I was told that he “didn’t know” and he thinks I would have to not only pay for the shipping back but also pay a restocking fee. I was literally stunned as it not like I changed my mind, IT LITERALLY IS DEFECTIVE.

I’m not sure where to go from here. It feels like in order to get any kind of support I have to make a YouTube video and/or contact the California Consumer Protection agency. This is a $4000 machine not some little thing and these VFD and Spindles aren’t that complicated. 0-5v = works, 0.1-2.344v = not correct.

I don’t understand, my Shapeoko 3 XXL was such a good experience with this company. What is going on?


I hear what you’re saying, and it doesn’t sound like the support people we’ve been hearing about here for the most part.

1 Like

I know I was stunned. He literally made me feel like I was the one in the wrong and isn’t going to help me because I didn’t buy their spindle. Even going as far to say if I had bought their spindle he would be happy to help me with this problem.

Its not a good thing if a company denies any responsibility in their product when it is clearly defective because I used something I already had that works fine. Especially considering ALL these VFD’s are essentially the exact same in how they function, including the carbide3d one.

1 Like

Asked after this on team chat and was told:

We have some isolation hardware in the 5 electronics to better control esd and Emi. You may need signal conditioning to connect to a third party vfd.

Thanks for the reply. Ill send that email asap and also post it here for posterity.
The VFD and spindle are a Huanyang 2.2kw 220v mounted to the wood bench on the complete opposite side of the table that the controller is on. The signal wire coming from the Shapeoko controller is a shielded 18 awg cable grounded on the VFD side. The wire that goes to the Spindle is a double shielded 16 awg cable with the jacket also grounded at the VFD side. (You don’t ground at both sides because of feedback loops.

This is the same setup MANY people are putting on this class of CNC.

I’m pretty protected from emi and esd up to the point of how I wired it should be good for a theoretical plasma cutter. In fact the 120v stuff for the shapeoko are on one circuit, and the 220 is on a completely different circuit, in a completely different panel, on completely separate service for power.

The issue is, and what I tried to explain to support is that even without the spindle being in the picture at all, the controller is outputting voltage. I’m talking about testing the signal coming out of the spindle connector on the controller without the spindle, vfd or anything even being in the room.

I really appreciate your response I really do, I’m not the type of user that needs support for stupid things, the bottom line is that the machine has to function as designed, nothing more needed for me nothing less.
This isn’t my first Shapeoko, and the PWM speed works perfectly on the other one that sits next to it.

It should not be outputting any voltage at all when just simply powered on, and absolutely should not surge when connected to with the computer.

I am not looking for support for the spindle, It works perfect in manual mode or controlled via external power supply, I need support for the defective controller.


Hey @WillAdams here is a video of exactly what the signal does when powered on and then initialized.

It is beyond me of how you condition this signal to something usable by any VFD.

I’m not really sure why this feels like a huge secret that I’m not in on. But I will say it doesn’t feel great.

I have looked at the manual for the DELIXI EM60 Series VFD’s, which was almost a clone of my manual for my VFD. DELIXI EM60 Series VFD’s are the ones Carbide3d resells and the functions of each are the same other than the analog input on those are 0-10v. I’m assuming
the “adapter board” in the listings of things in the store, a step up voltage converter. The Huanyang VFD accepts either 0-5v or 0-10v. And as I have stated I have fed 0-5v with my variable dc bench power supply into the VFD and it worked perfectly.

I could convert the 0-5v to 4-20ma that the Huanyang VFD also accepts and the voltage leak and surge would still be a problem as its just converting the voltage to current.

That would be fine and understandable, if it wasn’t for the voltage when there shouldn’t be and that spike to 5 volts when connecting. This is exactly the reason I contacted support. To get the answers to these questions or come to the conclusion that I got a lemon.

Jeremy, I’d be interested in what happens when that output has a tiny more load on it. I don’t know offhand what the recommended input impedance would be on your spindle, but I would like to see the output if you loaded the controller output to its rated load. I’m not sure you can ever find that, though.

The main thing you could do is plot the linearity of the signal that you are showing on the multimeter. You would need to use some gcode to simulate a range of inputs and then plot what each of those shows on the multimeter. Poor linearity would be the killer proof of a defect in the output driver that has a static DC level, but when a controller states a range that includes “zero”, that usually means there is some procedure they use to adjust to that level. It might be that the drive electronics on the output does this internally, too. That would be another suspect that is causing the problem.

Linearity is a main function of the controller.

The only load that I could think would be put on it is when its connected to the VFD itself. Which results in the voltage at 24000rpm getting cut in half to about 2.4 volts. If I use my dc power supply and turn the knob from 0-5v manually the VFD shows the correct RPM and frequency and does what is expected on the bench.

These Shapeoko machines all run the open source GRBL firmware which is Arduino based and SHOULD be using the standard PWM output from the chip as reference.

At this point I’m waiting to hear back from that email I was told to send which I sent. Al-tho the person I talked to on the phone when this all started said he would call me back yesterday and didn’t after he talked to the “engineering team”.

There are only two things now that can be going on at this point in my opinion.

  1. My controller is defective and they don’t want to acknowledge that
  2. Carbide did some tom foolery internally with hardware that only they know about and aren’t willing to share what is actually going on in order to lock people into ordering a sub 60 dollar VFD and sub hundred dollar spindle for 700+ dollars because they made it in a way where they are the only ones that know how to get it to work.

I would like to think and assume that its the first one, because the 2nd one is about as anti-consumer as it gets.

I am getting worried tho I will be honest, with the recent changes to carbide create not outputting actual gcode unless you pay for the pro version and using its own proprietary format for files, Vendor locking hardware and software is concerning. Especially when the entire thing is built on the back of open source projects like GRBL and Arduino.

I just want my new 4000 dollar machine to work. This is so frustrating. I upgraded from the Shapeoko 3 to the 5 and got less functionality!


They have the bolts packaged in the wrong box, i had the same issue, they were just in the wrong box and not in the open me first box like they should have been.

Regardless, sorry to hear about the issues, hopefully you get all sorted and up and running.

Believe me I looked. That’s what I initially thought also but alas I was wrong.

Thanks, I hope this gets sorted out also.


WOW! This is very disappointing that you have gone thru this with a $4000.00 Shapeoko! I am shocked as this is the first time I’ve heard of them treating anyone like this! I’m following to see how this turns out! New person in customer service?

subbed, interested to see how C3D handles this.

Kickstart backer for the S3 here.

1 Like

I finally got in contact with someone from Carbide support. A person named Brandon reached out to “repair the relationship” (his words). He was very friendly and helpful to the extent that he could be in this situation. This was the normal experience I have had and come to expect from Carbide3d and cant give him enough credit for sitting on the phone with me for almost an hour while I tried to figure out what was going wrong and while I vented.

Fortunately, we have come mostly to the conclusion that my controller probably isn’t defective as I was told even the offering they sell “surges and spins up” when connecting to the machine if you have the VFD powered on when you connect. If anyone with a 5 pro can verify that I would appreciate it. I did voice my opinion on how that is probably the most unsafe thing you can do, is make the spindle rotate when its not expected to, no matter how many stickers and warnings or obvious you think it is and whoever designed that wasn’t thinking as the e-stop button forces disconnect. That makes something like a crash recovery exponentially more dangerous. OR Imagine changing a bit and the machine randomly drops connection and you forgot to turn off the vfd completely. Likely you would have to manually reconnect and init the machine so nothing would go wrong, but what if it did.

UNFORTUNATELY, while being a perfect support person in both bed side manner and corporate professionalism he did say that not even they know how the thing actually works because they aren’t even told. This brings me to the conclusion that from my above two options this falls squarely under the 2nd, and rather depressing outcome. This doesn’t appear to be a support issue other than the first guy I talked to being as unprofessional as it gets, and more of a company structure and information sharing issue, OR CHOICE.

  1. Carbide did some tom foolery internally with hardware that only they know about and aren’t willing to share what is actually going on in order to lock people into ordering a sub 60 dollar VFD and sub hundred dollar spindle for 700+ dollars because they made it in a way where they are the only ones that know how to get it to work.

The end result of the conversation was still essentially “you are on your own getting your spindle and VFD to work with our hardware”, which I understand because I believe him that even the support team doesn’t have the information to help me if they wanted…

I was also informed there in fact are modifications to the open source GRBL firmware that is on the machine itself. I wasn’t made aware of what was changed, nor can I find the source code used which might be a violation of the GPL its released under but I’m not a lawyer. I did clearify if he meant the settings stored in EEPROM or the actual source itself. He did state the actual source code not the $ settings.

I have a couple angles I’m working to figure out what I have to do to make this work. Tomorrow I will break out the oscilloscope and see what is actually coming over that signal wire and figure out exactly what I have get to “adapt” the signal to be usable if I can. Firmware modifications still make me a bit nervous but I have no control over that. At the worst, I have a well built machine with a manual spindle, at best I can figure out how to get it working and share it with the community.

I want to again thank Brandon, as he really did try his best and did make me feel a little better about this purchase. The chip on my shoulder is definitely smaller than it was, but not completely gone. I’m still salty about this whole situation.


If you want a copy of the Grbl source, let us know at and we will get it to you (the modifications which were made were to enable Y-axis homing with two motors).

Yes, the Shapeoko 5 Pro will spin up the spindle on power up/connection — I view it as a reminder to disable the spindle using the pendant.

1 Like

Interesting I have never noticed mine doing that. Will have to check next time I power up and connect.

Thanks Will. That makes total sense he was talking about speed but he wasn’t sure I could tell. Source is a different beast altogether.

Maybe I’ll take you up on that and compare it to the way it was done with marlin for the 3d printers. Those auto square themselves also with the right flags being turned on.

That’s still an interesting and slightly off-putting decision to allow that spindle spin up like that. Also when you power it off with the pendant the controller stays powered, and the fans spin occasionally for seemingly no reason randomly even if I didn’t turn the machine on that day. I put the whole thing on a switch and turn off both the pendant and at the end of the night turn off the switch.

That and the constant voltage coming over the signal line were the only reasons I thought it was defective and called. As that behaviour is, well, odd.

Appreciate the response.

1 Like

The pendant is an e-stop — it’s not an on/off switch — that’s on the control box itself.

I understand what your saying. Instead of using the toggle on the controller I put the whole thing on a switch. And kill power to the entire system.

I was referencing the pendant making the machine appear powered down, by turning off the gantry lights and everything without getting too deep into it.
That makes it pretty easy to forget the machine is still powered unless you can see the led and or hear the fans come on randomly.

It’s just choices I wouldn’t have made, I’m not complaining about it I’ll get used to it. I’m just pointing out this machine works completely different in a number of ways than your other machines have.

It’s a known but muted issue. If you want another take, email Daniel.


Whilst it’s a bit bodge on a bodge (analog voltages for control are so 1970), might this be a job for a little arduino nano or ESP board? Read in the Carbide controller voltage output, output a PWM voltage to your VFD based on a range or lookup table?

This might allow you to eliminate the 0.1V behaviour and also map the set speeds to VFD speed more effectively as it appears there’s no fine adjust for that in the C3D controller.

Depending upon what VFD you have, you may also have the option to send something slightly less ancient (RS485 Modbus, ewww) and digital to it. On some of the HuanYang you can set PD002 to say that speed control is over the Modbus interface (warning the HY Modbus is not quite Modbus).

Edit, or just buy the PWNCNC pigtail…