Simulate Toolpath

I’m not getting the option to simulate the toolpath. Is it the Carbide 3D License limitation or is it a bug in MeshCAM 6 Build 26 (What I’m using)?.

I was of the belief that toolpath simulation was a separate product from GRZ Software called Cut Viewer. I don’t see it linked on the main page there, but the old URL still goes to it:

There’s also a Free/Open Source product called “OpenSCAM” (great name, eh?) available at, that you can use to get some preview of your toolpath. It’s a little clunky, but can help diagnose obvious problems.


My own MC license is Pro because it predates my Nomad, but I have asked Rob to update the license. Pro does have built-in simulation as of V6, but I don’t know what level the Nomad license is (standard or Pro).

CutViewer is indeed an independent program that Robert sells, and I have used for years. It was written by a guy named Stanislav (“Stan”) Gorkun. It is always good to have independent verification, though I am impressed by V6’s built-in simulation. Since it is a separate process from actually generating the gcode, it probably counts as independent verification…

The carbide3d license with the nomad is for meshcam pro. It does have, or should have, toolpath simulation. However at least one previous beta had an error in the toolpath viewer.
I have beta 27 and the cut simulation and toolpath viewer work well.

Interesting, i do not have the the toolpath simulation either in the version for my Nomad. Is there a way to get that?

I have MeshCAM 6 Build 26 which is the latest for Mac OSX. I believe that since v6 Simulate Toolpath is included. I have asked thie question before but has gotten no answer. Is MeshCAM Pro License any different from MeshCAM Carbide 3D License?.

That’s weird. I also have MeshCAM 6 Build 26 / Carbide3D License, and I don’t see simulate toolpath anywhere.

Should it show up in the dialog after generating a toolpath? Or is it a separate menu item?


(Edit: I’m also on Mac)

Yeah, on the PC, after generating a toolpath I get this dialog with the option:

I have the PC version that came with the Nomad. (MeshCAM 6 Build 27, Build Date: 03/10/2015

Looks to be a Mac bug or limitation, like the big zero position arrows.

I’m running MeshCAM v6 build 26 on a Mac, and have noticed that you only get the Simulate Toolpath button when you are doing 2 sided milling, and then ONLY when you are viewing the toolpaths on the back of the piece. Once you activate this mode, however, you can view both front and back simulations. Pretty weird!

As for OpenSCAM - I use it all the time. If you monkey around with it a bit you can get some useful info. The most useful thing about it is that it estimates the cut time MUCH more accurately than MeshCAM.

Big origin arrow problem is across the board with V6. I run Windows and have the skinny arrows too.


I can confirm that behavior, just reproduced it on my Mac with a freshly downloaded and installed version of build 26.
Does somebody know if that bug exists in build 27 on the PC as well? Or in the ‘regular’ non-Nomad-Meshcam version?

Oliver, I’m running build 27 in 64-bit Windows 7, and simulation works for single, double, and 4-axis jobs. I have Pro, but not Carbide, license.


Thanks Randy! Yeah the simulation is probably not included then in the carbide license :frowning:

Rob updated my existing Pro license to Carbide 3D Pro, and it still has simulation for both 1 and 2 sided machining under Windows 7.


I get simulation when I use “two sided machining” but not when I use “3D machining”. They must have a bug that doesn’t include the GUI button for 3D machining since it works for the other.

I use MeshCAM Pro/Art and I always have an option to use simulation. It might be that the basic MeshCAM doesn’t show the simulation? @Randy will know this off the top of his head.

One can also emit the G code and run a simulator separate. See Camotics for a free one.


I do not have simulation for 3D, have not tried 2 sided.

It shows up on “two sided” which makes me think they just forgot to link something since the functionallity is already there.