Skewed Y axis on XXL and repeating jobs misaligned

I don’t know if this is even the right terminology, but here’s my problem.

I attached a 2 ft by 2ft square piece of MDF to the wasteboard (I am using misumi Tslot). I ensured the edge of the MDF was up against the edge of the front steal cross member.

Then I cut a pattern of slots that are 20mm wide, by 520 mm long. Great. Looks good. After the job ran, the machine goes back to home.

Load the next file, which is to “pocket” some holes in some parts that are placed in these 20mm by 520mm slots, the slots are supposed to serve as a consistent means of locating these parts.

The left side starts, makes the holes nicely (2 on each end of the part). Then it goes to the right side, and it is skewed toward the front, making the holes off center by at least 1-2mm. Just to thrwart the potential responders saying check your file, I’ve already done that. The designs are Fusion 360 and yes the paths are parallel to the X axis.

Another example is, cutting a circle job, then re-run the same job. You would expect it to basically “air cut” the second time around, but it actually cuts more material towards the rear of the hole.

In between the two jobs, nothing physically has moved. It’s just that the machine, after it goes “home” and comes back things get wonky. Is the right Y motor and left Y motor on the same drivers, getting the same current? What could be the problem, and how can I “calibrate” it?

Thanks,
Mark

Hey Mark,
Welcome to the community!
What material were you cutting the holes in? What type of CAM operation for milling holes? It’s possible you lost some steps on the first holes.

Edit: You edited your post during my reply. Have you tried the circle cut?

1 Like

The point is it’s not the type of cut operation (I was using 2d pocket and circular) it’s that the machine won’t repeat subsequent jobs in the same position, and I need to figure out how to address that repeatability.

My original reply was that it’s possible that steps were lost during the, sometimes high load, action of milling deeper holes.
Can you measure the lack of repeatability without adding cutting forces to the equation?
Use a sharp v-bit to make a small mark at XY zero, home, and return to that spot. How far off is it?

3 Likes

Check your set screws on the steppers of the axis in question. I had a very similar problem with my machine right after I got it. Almost all of the screws were loose, allowing for movement in X and Y. I took all of them out and locktighted them about three weeks ago. No issues since.

3 Likes

One thing you might want to check;

Are your jobs getting close to the movement limits of the machine?

If so then you may be losing steps as the machine runs into the physical limits, I’ve had this happen with some Fusion CAM jobs, I heard the stepper grinding sound and then when the job started cutting the next pass in the wrong place realised what I’d done wrong. I overran the movement dimension to the back of the machine so the next moves were all too far forward towards the front. The machine will only ‘realise’ this when it re-homes.

From the sound of your circle job, slippage is more likely but, don’t know where you ran it.

2 Likes

No, it was just some small holes and pockets.

I did check the set screws, they were not as tight as they could be, and the gantry bottom wheels seem a bit loose. I will adjust those tomorrow and re-run my tests.

2 Likes

When you turn on the machine, the stepper motors can jump plus or minus a step in opposite directions. To ensure your two Y motors start off perfectly in sync the same way every time you power on the machine, you can move the gantry to a standard reference before you turn on the machine (ex. roll it to the front of the rails, or some other repeatable position.)

3 Likes

This is not really the issue. The steps to repeat this test are:

  1. Create a job that cuts any kind of pocket, etc.
  2. Run the job. When he job completes the machine homes.
  3. Run the job again.
  4. The machine will not cut the pocket in exactly the same place, thus, a 2 inch hole is now enlarged and mis-shaped because of the error.

I can even observe the sloppy nature using this:

  1. Move the Z to the front of the machine where it overhangs the front rail
  2. Use a caliper to measure the distance from front rail to cutting tool
  3. Move X along the path, from far left side, to far right side
  4. Measure again. Note the two numbers.
  5. Now move it back to the same original X position, repeat the measurements.
  6. On my machine, these numbers keep changing.

I am thinking this is play in the wheels on the left/right side gantry plates.

Curious… do you have mechanical or proximity limit/homing switches?

If the V wheels are properly adjusted by the eccentric nuts: http://docs.carbide3d.com/support/tensioning-eccentrics and the pulley set screws are tight and holding the pulley securely in place: http://docs.carbide3d.com/shapeoko-faq/shapeoko-3-how-to-check-the-pulley-set-screws/ and the belts are properly tensioned (see the assembly instructions for your model) and the machine is square and all the electronic connections are in good working order and the controller is working correctly, then of course, this shouldn’t happen.

To eliminate the software, please check it in a 3rd party previewer such as CAMotics: https://camotics.org/ ​ ​The machine is able to move based on: ​

  • impulses from the stepper driver — usually if they don’t work right there are horrible noises
  • sent through the wiring — check the conections and wiring — if you or a friend have a multimeter use it to check for continuity
  • received by the stepper motor — these almost never go bad
  • which rotates the motor shaft — check that this is true and not bent
  • which rotates the pulley — check that it has two set screws at least one of which is on flats and that they are secure: https://docs.carbide3d.com/shapeoko-faq/shapeoko-3-how-to-check-the-pulley-set-screws/
  • which pushes/pulls on the belt — make sure that the belt tracks true through both the pulley and the idlers and is in good condition, secure at appropriate points and well tensioned
  • which moves the machine along the V rails guided by V wheels — make sure that the latter are properly adjusted https://docs.carbide3d.com/support/tensioning-eccentrics/ and the former clean and in good shape

For electronic accessories, check the connectors and the length of the wiring.

Additional things to check which we may have gotten wrong:

  • verify that there are a consistent number and placement of washers for the V wheels
  • check the V wheels and their bearings for play — if you find this, remove and disassemble the wheel in question (you can use a bolt for leverage to work a bearing out) — check that the precision spacer used as a shim in in place and use a caliper to verify that the internals of the V wheel were machined properly (my understanding is they are turned from extruded round stock on a lathe)

While the machine is complex in terms of the sum of its functionality, when you break it down to a single axis and examine each component in turn it’s quite simple (and elegant — it really deserves to win some design awards).

If you find anything untoward, let us know at support@carbide3d.com and we’ll do our best to work through this with you.

No homing involved in this test?

1 Like

I’ve had the same issues on my new Shapeoko XXL as the OP. I feel like I’ve wrestled the machine and tried every suggestion given to me by support and that I’ve read in forums and still had no luck. When my machine goes back to whatever point I’ve zeroed, it doesn’t go back to the exact same spot. I can’t run the same Gcode twice and get the machine to trace the exact same shape(s) as the first run. It will invariably be off by 1/16" - 3/16" or more.

I’m going to go back and check every little thing from start to finish to make sure I’m not missing anything, and I sure hope after all of that that it will finally work properly. A question: Is it possible to ruin the Vwheels by turning the eccentric nuts 360 degrees? In other words, if I feel like I may have over-tightened a Vwheel, we’re told not to go counterclockwise, so I have to continue clockwise all the way around to get to the desired spot. Does doing this crush a Vwheel?

A related question: it seems like my Vwheels tighten more during use to the point where it’s hard to spin them by hand, even though I only tightened them until they were engaged with the rail in the first place. Do I need to worry about this?

I’ll keep reading this thread hoping that Mark can figure out this problem. I’ll also report back if I find out any of my own answers!

If you take the bolt out you can remove the V-Wheel and inspect it, yes it is possible to overload them and they can split down the middle which results in a loss of tension and obvious loss of position control.

I used the Loctite thread lock compound on all the things that kept coming loose on my machine, that included the eccentric nuts and now they need a good shove with a spanner to move them and they stay put for a reasonable length of time.

There’s a checklist of things to go through maintenance wise in Julien’s ebook. Which is a good reminder of the things you forgot.

I check the lower V-wheel tension, belt tension and give the spindle a good shake to see if anything will move every time I start the machine up, I also listen for any extra noise indicating stuff has come loose.

1 Like

Is your issue persistently in X, Y or both?

If the path varies then one of a fairly short list of things is happening most of which are covered in Will’s post above;

  1. Your limit switches could be fouling on the drag chain as the X or Y axis go to the right or rear positions, this can mess up where the machine thinks machine zero is. The first thing the machine needs to know is the absolute position in machine co-ordinate space which starts up, right, rear. I’ve had this happen and it took me a while to figure out what was going on, I was stood to the side of the machine one day and caught it in the act. I now check the drag chain isn’t fouling the limit switch. (maybe I didn’t install them quite right?)

  2. You could be missing steps on the motors due to excessive force required to move an axis, there is no feedback loop on a Shapeoko, it steps and trusts, if you hear that characteristic hammering grind of a stepper losing steps, the job is toast, stop it.

  3. You could be losing motion by skipping teeth on the belt, same effect as losing steps, machine trusts that a step is a step, your belts would need to be quite loose or the belts not looped around the motor drive pulley correctly.

  4. You could be losing motion by the pulley slipping on the motor shaft, check the shaft as per the instructions on the pulley set screws in Will’s post above

  5. Electrical issues causing the motors not to step for some reason, connection or controller hardware problems.

So, if you power up your machine and watch closely as it homes;

a) Do the limit switches hit the end plates and not a bit of loose cable tie, drag chain or some other cruft?

b) Jog around in X and Y using fast, does the machine move freely and sound the same all over the X, Y range? Use the rapid position to go to Centre, North etc. does it move smoothly and sound the same all over?

c) Set zero where you can test it, do ( b ) again for a while, jog back and test the zero, if you can lose zero doing this there’s a real problem

If you can get through that lot, the belts are suitably tight, the steppers don’t slip or grind then back to trying to actually cut.

Usually, if the V wheels are over-tightened, then loosened they will go back to their shape if left overnight.

Contact us at support@carbide3d.com and if you have any problematic V wheels, send us photos and we’ll do our best to work this out with you.

1 Like

Thanks for your very helpful reply! I will look into all of those possibilities. What do you mean “limit switching fouling on the drag chain”? Getting caught on it at some point? One thing I’ve wondered is what the limit switches are actually responding to. Are they supposed to hit the metal plates? My y-axis limit switch almost hits the back plate of the y-2 rail- I can fit a piece of card stock in between. My x-axis limit switch only comes within 3/16" of the y-2 motor plate. The back of one of the top Vwheels prevents it from going all of the way because of the frame of the z-plus. Even if it could, the x-axis limit switch would still be 1/16" away from making full contact. Does it need to?

I printed a small block with a 1/8" slot that I fix onto the back right corner (black) rail, so the end stop catches it rather than hitting the belt bracket. It seems that the arrangement is not ideal, the way the Y end stop is mounted to the X rail. But the printed block helped. I also re assessed my original assembly, and re-squared everything. Drilled out the holes in the black frame parts to allow a bit more fudge factor. Lastly, I tightened all the MDF to frame connections, and then mounted my Tslot aluminum table to the top of the MDF with long M5 bolts and new holes/threads into the frame. Substantially more ridged now. I milled my first aluminum part (out of 1/8 sheet) and it was great. Also repeatability has improved a lot, to the point that i can re-run the same hole twice with no offset.

Thanks everyone for your suggestions.

5 Likes