Skipping "Playback" in simulation

I have a project with an estimated carve time of an hour. When I click Show Simulation, it takes well over a minute for the playback to complete with the speed set to maximum.

Obviously, there should be a way to bypass this. Usually all I’m interested in is the result of the simulation, not watching the animated playback that gets to that result.

The way it was explained to me is this is roughly the amount of time it would take to calculate the final result, just that you would be looking at a hourglass or progress meter instead of watching the cut.
Obviously, it’s a little bit longer because it has to display the graphics, but if you take it back to a version before 769 you could see how long it takes without the simulation.

An ideal situation might be to not have it play at all when the dialog pops up, allow you to change the settings to your preference, then hit Play

1 Like

Interesting … But if I let the animation run and then click “Play” after it’s finished, it takes just as long for the animation to run the second time. So that would indicate that it’s not the calculating that’s taking so long – unless the calculating is redone each time you click either Play or Show Simulation without having changed anything (which would be dumb).

It may actually be ‘choked’ by the playback speed a bit. Fortunately, it starts by default on the fastest speed.

Hey, Me: Maybe the animation can’t be bypassed, and maybe it’s the toolpath calculating that’s actually taking up the time, but in any case the calculating/animating time can be cut to approximately 1 quarter by turning off “High Resolution Simulation” under the View menu.
HTH,
Me.

2 Likes

Wow, thanks, Me! :+1: