SO3 & ArtCAM Toolpaths

I’ve read the other articles on this topic and I just can’t seem to get this to work. I’ve tried using both the Mach3_4 inch (and mm) post processors as well as the generic gcode in Artcam. No luck.

Universal GCode sender is giving me this error:
Error while starting file stream: Cannot stream while there are active commands: G20 G91 G0 Z0.1, G91 G20
(That’s from the 2.0 nightly build and 1.09 for Mac OS X, although 1.09 didn’t give the commands list)

Carbide Create is having a problem maintaining connection (I’m not sure if these things are related).

Has anyone been able to use ArtCAM with the SO3, if so, what are you using? If not, is there another tool like artcam that lets me do things like bas reliefs. I tried Fusion 360 and process is too time consuming. I found errors with MeshCAM…

Ive used artcam with my so3 on windows 10.worked ok for me.The reliefs are great

Would you please document the details of:

  • which version of ArtCAM
  • which post-processor was used
  • what Comm / Control program did you use to send the files

2011 ver and i used cm to run it

1 Like

What is cm and what post processor did you use? Mine is horking on the post processors they told me to try.

I am running Mac versions of everything but Artcam. I don’t get these errors for any app I can output grbl from.

Carbide motion,not sure about the post processor,i followed some vids on youtube and just winged it,But it worked.look for roger webb on youtube he has tons of vids about artcam

I’ll check it out. Thanks!

1 Like

Can you point me to what you are referring? I can’t find anything that Roger Webb has done with Shapeoko or ArtCAM and Shapeoko.

Just go to roger webbs youtube page and put “artcam” in his search and it will show you everything he has done on it.He doesnt do it on a shapeoko but with all the info he provides it isnt hard to figure out,I finally got my shop all cleaned and some projects done so if you still have trouble let me know ill go to the shop this week and run artcam again as its been awhile,I know for sure i use to do some of his reliefs on it,made the toolpath saved it then put it into carbide motion and it ran fine,

also pretty sure i used the *NC option

I aslo sent a question directly to you in your msg box and no reply,The question i asked will make a huge diffrence lol

I just sent you a reply, didn’t realize I had an inbox here. :slight_smile:

I’m not having any problems figuring out ArtCAM, it’s literally just getting an output that will run from the demo file. I’ll check out Webb for other stuff, but what I need right now is a way to post process a tool path that will actually run on the SO3.

I know GRBL doesn’t support some commands and I imagine that’s why these are failing. Is there a find and replace action where I could modify a G-Code file to work? As in output to Mach3 and substitute correct commands for what is not supported? Or is that a really simplistic view? (Where a straight substitution, i.e. G20 = G75 wouldn’t be sufficient, G20 is maybe a more complex command?)


Oh, and obviously, if you can hook me up with that post processor from ArtCAM that just works, that’d be fantastic.

I’ve been trying for about 9 months (as time permits) to just do some bas reliefs. I started with MeshCAM and ran into a bunch of bugs. Invested a ton of time in Fusion360 and was successful, but it’s an inordinate amount of time to do something like a mesh in that tool. Finally broke down and expanded to Windows apps in my search. ArtCAM looks perfect for what I want to do, I would just so love to make it work. (I’m more of a graphic designer/software engineer than an industrial design engineer. I really just want to put together some beautiful designs and output them.)

Im really not sure and i havnt used mach 3 with it,i was using the carbide motion and pretty sure i chose the *Nc for the output

I’ll try the *.nc later tonight and let you know. Thanks again! -M

Well right now im kinda doing a few things but how about after dinner ill go sit down with it and see what i can put together for you,look for the *Nc one tho for now

Ok sounds like a plan,i will def msg you later about this

The .nc post processor didn’t work either. I don’t think these are related, but I’m also seeing some communications problems right now, been looking at advice from my other thread about grounding and I’m starting to think there’s a problem with my arduino board on the S03.

When I run a grbl file from a previous job, it runs, but at some point I get the comm error (unresponsive CNC), when I run anything I’ve output from ArtCAM, it really appears to bung up instantly. Depending on the tool it says invalid tool path or unsupported code, or just sits there and tells me that there are commands in the queue.

Let me know your thoughts.


I still havnt had a chance to play around with it,try .Tap…also what version is your board?

I didnt have time to run anything but i did find my old reliefs and they are .TAP so thats what i ran it as in carbide motion,hope this helps

I’ll try that tomorrow, thanks again! -M