SO3: Beta issue with Jogging

I installed The beta file and cannot get my SO3 to jog. What steps do you need to take to control the machine thru the software?

Hi there @Lewscrew,

Since you’re asking a related (but new) question I figured it deserved it’s own thread as a support item. I’ll check with Rob & Edward about this and see what we can come up with for you!


I have my SO3 fully assembled powered and connected to my Mac Book Pro (OS X 10.9.5) running Carbide Motion v2. When I click on “connect cutter” I get “GRBL error: cannot open port for Nomad”.

Mac system profiler shows that the device is connected to the computer. Also tried GRBL commander but the only ports shown were bluetooth and wireless so the program couldn’t see the SO3. I’ve exhausted all avenues of troubleshooting I can think of.

*Apologies if this isn’t the correct forum for this question.
I’m very familiar with 3d CAD but haven’t run CNC since college.

@projectMEHL - The Shapeoko will show up as a standard serial port on the machine. If you go to a terminal window and type “ls /dev/tty.usb*”, what shows up?

@Lewscrew - Can you start Carbide Motion, the press “L” to open a log window, and then connect and try to jog like before. When you get a failure, send me the contents of the log window.


@robgrz When I run the script in terminal it says “No such file or directory”

@Lewscrew When I open the log in Carbide Motion it initially says “Test Waiting…”, I then press the connect cutter button and the “GRBL Error: Cannot open port for Nomad” pops up. Nothing changes in the log window, it still says “Test Waiting…”

How about:

ls /dev/tty.*

@robgrz, I sent you the log file last night responding to the email. I am able to open Log file , M, and read the settings in the controller. No movement from the motors whatsoever.

I’m also having a problem getting Carbide software to jog my Shapeoko 3. Here are some screenshots that might help diagnose the problem. I went through the steps listed above. It looks like the computer is recognizing the Shapeoko as a usb device.

I’m using Mac OS 10.10.3, and Carbide 2.0.314.

Thank you for taking a look!

Can you do the following:

  • Connect Shapeoko
  • Open Carbide Motion
  • Connect to Machine
  • Press “L” to open a log window
  • Press “M” to open the MDI window
  • Enter “$$” and press Send
  • Send me the contents of the the log window.



I am having the same issue. I am using the Shapeoko. Yesterday I was cutting ABS plastic and in an effort to clear out some of the chips that were being created I went in with a vacuum. I must have slightly bumped the machine, as CM crashed and I reopened. When I reopened CM, I was getting this error. I have opened the log window while trying to connect, but nothing appears. Every time, whether the machine is on when connecting or off, I am getting this error when reconnecting the cutter. Any ideas?


Mine started doing this today. Homed, measured tool, CM crash…now no matter what I do I cannot connect. Anyone figure this out? I’m stuck

Nomad CM weirdness like this happened to me. Could you please try this and report back?


Hi Guys, just reading through this thread – I can relate to this, as I experienced a similar problem when I first started working with the SO3. The scenario went

• Just finished building the SO3 with an Acrylic cover.
• Loaded software onto my Mac Book - Carbide Motion version 14-Oct-15.
• Started testing it. Was working with Aluminum, all looked well.
• Used the vacuum after tests were completed and powered down, no problems.
• Became more comfortable and started vacuuming intermittently during operations.
• After a period of time, I would experience an error in communications with Carbide Motion.
• Usually cleared up by powering down and disconnecting power for 30 seconds or so.
• About this time I started to notice some static when cleaning the SO3.
• The SO3 crashed during a 4-hour job in Nov-15 and failed to recover. I tried every thing again but no joy. A few days later prior to attempting to reload he Firmware the system started communicating again between the SO3 and Mac Book – still not sure what the problem was.
• Also noticed that connecting the power to the Mack Book would cause a hiccup in communications with the SO3.

Since then,
• I have the power plugged into the Mac Book at all times
• I Disabled “Sleep Mode”
• I have upgraded to newer versions of Carbide Motion.
• I do not vacuum mid job.

The system now, seems to be working without issue.

My opinion is that, there may be issues with an induced spike in the communications line when any power related to the working environment, changes. For example, static from the vacuum, adding power to the Note Book, turning on/off the Dewalt Router etc. Some folk have also experienced issues on power supply line fluctuations.

I have not used an oscilloscope to verify this opinion yet, so it is still only a wild guess.

See attached link to the problem

Hope this is of some help.