SO3: Compiling latest Grbl [SOLVED]

I want to install the latest version of Grbl on my S3 controller. I downloaded the source from GitHub, modified the config.h file and compiled the hex with the Arduino compiler.

I used my USBTiny programmer to flash it to the controller and it appeared to load fine.

But when I connect with bCNC it doesn’t seem to be responding correctly. It makes the connection, but Grbl doesn’t appear to be responding.

I’ll be doing some more troubleshooting this evening but I was wondering if there was a list of any special S3 specific settings in config.h that I might have missed.


1 Like

Digging in the Grbl source I see one thing that I missed. In config.h I didn’t change




But as far as I can tell that shouldn’t affect the communication. I’ll re-compile and re-upload this evening and then do some testing.

Okay, well, I solved my own problem.

I used my USBTiny to flash a bootloader onto the controller then I used the Arduino IDE to compile and upload the code through the USB port.

That appears to have worked quite well.

Of course I didn’t write down all my Grbl settings before I started so now I have to re-calibrate my steps/mm settings. Oh well, at least I have a process for that.

if you don’t mind… and since i have a sparkfun SO3… do you know what the default grbl settings for the SO3 are?

EDIT: never mind, i shoulda searched first — my apologies.

Anyone know where I can get a copy of that settings file? This link is broken.

maybe it is this one?

1 Like