SO3: X motor stuttering / shaking

So we bought this machine for my shop and we are having trouble figuring out why the x axis motor is shaking. The symptoms look exactly like switched wires to the control board, but the motors are all connectors pre-installed. Y and Z axis are fine.

We also inverted homing direction through Carbide Motion. Maybe we changed something else? We’ve checked the grbl settings with Ctrl-1, strangely everything is default but homing is still inverted to front left instead of back right.

We have also tried the following things:

-Checked wire continuity
-Unplugged and reinserted all connectors correctly

What should we do?


You’ve gone 24 hours with no response, so I’ll try to start the ball rolling for you. I don’t have a machine yet, so I don’t know if I really can offer much help, but:

(1) Have you tried a clean install of the software, leaving things at their defaults, and seeing if you still have the problem?

(2) Have you checked to make sure the X axis is not binding mechanically?

(3) Have you tried swapping the X and Y to see if the problem moves, or stays on the X axis?

The things which you’ve tried cover the trouble-shooting stuff from

Agree that you should try swapping the motor leads.

If that reveals a bad stepper driver or motor, contact and they’ll get you squared away.