SO3 z axis and y2 motor

I assembled my new xxl and seems the z axis is reversed where z+ drives the spindle down. This was quite the shock when it drove the maker into the wasteboard like it was trying to murder someone on the hello world.

The other issue is that the y2 connection in the board won’t drive a motor. All the motors check out on other ports and it’s just the y2 port that won’t work.

Any suggestions?

1 Like

The Z is an easy fix, but if the Y2 port is bad, the board is bad, and you should contact support@carbide3D.com to start the replacement process.

What’s the fix for the z axis?

Are you familiar with checking GRBL settings?

http://docs.carbide3d.com/article/38-shapeoko-3-default-grbl-settings

@Murdocjx

According to the Graph - if your Z needs to be flipped and the $3 value is currently 0
Then:
$3=4

Heres the link for all the info on GRBL and shapeoko:

http://www.shapeoko.com/wiki/index.php/grbl
Will is taking the minute off.
:laughing:

2 Likes

Ok perfect. How do I actually make that edit in the code though?

To make that change

  • launch Carbide Motion and connect to the machine
    ​ - tap M for an MDI window
    ​ - type the command

    ​$3=4

    ​in the box and then hit enter or send

Then type $$ to view the change

$3 should be 00000100 now

(It was $3 00000000)

Awesome worked perfect! Now any way to activate the Y2 port?

Are you good with a soldering iron?

I’m kidding, refer to me answer Way Up there ^^^^

Haha nope! Thanks for the help with the z axis though you guys rock!

You’re welcome. I was trying to not waste your time knowing that you had a bad board (Y Error)…and there was nothing we could do to fix it…

Thanks for playing along.

@Murdocjx

Email support

2 Likes

Ran the process for the SO3 z axis and y2 motor. Mine is missing the line $14=1 (auto start, bool) Is this a problem?

David,

1)[quote=“Spyder00, post:14, topic:3401”]
Ran the process for the SO3 z axis and y2 motor
[/quote]

What process?

  1. Are you stating that line $14 is missing, OR $14 = 0, what exactly do you mean?

Without Auto start set, one has to send a command to get the machine to begin moving:

http://www.shapeoko.com/wiki/index.php/Operation_Troubleshooting#Machine_won.27t_start

auto cycle start ($14) has been turned off
Note that turning off auto cycle start requires that one begin the machine manually by typing ~.

It’s missing. Have to fill in 20 character’s xxxxxxxxxxxxxxxxxxxx

Not sure if it defaults to on or off — it should be harmless to enable it if it defaults to on.

Got my replacement board and everything works perfect.

1 Like