Software for accurate dimensions


I just purchased a Shapeoko Pro-5. I am looking to machine a taper and hold the dimensions from a 3D model made in Solidworks, importing an STL file into Carbide Create Pro, doing a rough toolpath and then a finish toolpath in CMotion as recommended by William @ 3D-CC.

The part mounted flat on the spoil-board, starting with a blank part of 1.50" wide x .50" high rectangle as pictured, using the top as a 0-datum for the cutter … part length is irreverent its about the taper cut. What I want the machine to do is start at the .50" height and cut a taper over the 1.50" length down to the .25" dimension at the opposite end accurately ending up with the finished dimensions. See picture.

After scaling the STL 1:1, I ran the program. What happens is the 1.50" width is correct but the .25" dimension is way off.

I then contacted William again at 3D-CC and he replied to use MeshCAM to achieve this.

Before I purchase more software, has anyone tried to make fairly accurate dimensional parts from 3D models on the Pro-5 and if so, any recommendations on how to do it or software used.

Thanks for any help pertaining to its post.

It should be possible to adjust the Carbide Create Pro file to get an accurate dimension.

You can check by drawing geometry and setting its height to equal and verifying it in the 3D model.

Post your file?

Here is the STL file …

OK, so the image above is a side view. The part is 6" x 1.5" x 0.5"

In CC, setup your part to be 6" width, 1.5" Height, 0.5" Thickness.
In the modeling tab, Import the STL. Orientation: Back, Height: 0.5"


1 Like

Hi Tod,

I opened CC Pro. Set my material blank size to 6"x 1.50" x .50" thick, Set my 0-datum for the tool to top of blank, imported the STL file (should be to scale from the 3D Model), , fit part to blank, ran toolpath in R & F, looked at simulation, cut part … the bit only cut the taper .062" deep at the .25" dimensional end. Something is not scaling correctly or I am not setting it up correctly. Have not found out why yet.

P.S. Thanks WillAdams too.


I don’t understand, “fit part to blank”. Here are the settings I used, and the G-Code comes out correct.

No, the height will not be to scale. The height defaults to 0.1181" (3mm). You have to set it to 0.5" if that’s what you want.

1 Like

Hi Tod (with 1 ‘d’),

Okay, I will try the settings you have in the post above an see how it works out. Thanks for your time replying.


1 Like


I tried what Tod1d suggested and it worked fine, thanks.

Q: In 3DC-Pro on the 3D Model menu, The X-Y scale seems to be in mm even though the JOB SETUP menu is set to “INCHES” … is this correct or a bug?


I think CC assumes the STL file is in metric. STL doesn’t define units.
Either way, it scales it up to fit the workpiece, or selected vector.

1 Like

Tod1d …

In Solidworks one can save the dimensional units, in this case “INCHES” to save the STL file in. When importing the STL file in to 3DC-Pro it reads it as “mm”. I did try 1 thinking the scale was 1".

That was one issue I could not figure out until you posted a picture of the 3D MODEL menu above … X-Y SCALE = 25.4mm (1"). This made the part full size.


Yes, you can specify whether you want Inch or Metric numbers in the STL file. But once it’s in the STL file there are no units, just numbers. If you use a software that allows you to specify which units the STL was created, then it will import accordingly. CC does not give you that option, but it does scale the data to fit.


This topic was automatically closed after 30 days. New replies are no longer allowed.