Speeds and feeds, GWizard, max feed

I just recently was looking through the forum and noticed some folks are running some really high feeds. I’ve been using GWizard for several months and when I use the ShapeOKO defaults it’s always 100ipm for max feed. After seeing some folks running much higher I did a little searching and found the SO3 default is 5000mm/m, which is roughly 196ipm. So I went out to the shop, opened CC, drew a 6" circle and set the feed at 5000mm/m, fired up the XXL, loaded into CM and let 'er rip! Sure enough it goes in circles at 5000mm/m. So I looked back at GWizard, went to the setup tab, set max feed to 5000mm/m, hit save. Then I pressed the mm or inches button and it defaulted back to 100ipm. Pressed the button back to mm and it set at 2540mm/m. Bug? Anyone else notice this? Am I gonna burn something up going that fast? I know it’s still going to be bit/material dependent, but is this right? I also checked my Grbl settings with $$ on the MDI panel and I’m set at 5000mm/m.


The thing is, even if one sets the feed rate at 50,000mm/min., it’s something of a moot point since the machine can only accelerate so quickly and move so fast — the thing to really worry about burning up are:

  • the brushes in the trim router — don’t run it any faster than you need to
  • the tip of the endmill — if it spins in one place too long / removes too little material (it’s the chips which carry away the heat built up by the friction of cutting) it’ll lose its temper and sharpness

With the hobby CNC routers, usually what is done is we try to make up for lack of spindle torque by spinning the endmill faster for inertia to power through cuts, and reduce depth of cut to reduce the cutting forces and the need for torque and the rigidity which is needed to take advantage of it.

We have an entire page of stuff on this:


and no real consensus — the best technique I believe is to:

As I’ve noted in the past, what I really want to see is a physics-based simulation which will take a given material specification and set of toolpaths and then work out the optimal feed rate and spindle speed based on how much material there is to remove at any given point — arguably that’s what the fancy CAM approaches such as trochoidal milling and adaptive clearing are doing.


Thanks Will, you’ve once again provided a ton more food for thought to my smallish brain, haha!!! What I’m getting at more though, and I explained very poorly above is there some reason why GWizard (which I know isn’t a C3D product) defaults, and even tries to switch back to a max feed of 100ipm? I run a SuperPID for my Dewalt which gives me 5000-30,000 RPMs, which I have been able to set as the default max/min RPM in GWizard with no issue, but max feed always wants to revert back to 100ipm, maybe it knows something I don’t? One reason I also question this is because with some materials and some bits I am constantly getting a max feed warning, meaning at 100ipm the bit will rub and dull instead of cutting. But if my max feed is actually 196ipm (5000mm/m) then I probably wouldn’t be getting these errors in some cases, it would just up my feed to 1XX or whatever. So I’m wondering if it could be a bug in GWizard (which I could report to them) or if there is really some reason to not go faster than 100ipm?




I dunno.

Bob Warfield did a pair of guest posts on the Carbide 3D blog,



and now has a Shapeoko of his own:



so I’m hoping that we’ll get something — Shapeoko-specific improvements in G-Wizard at a minimum.

As I’ve noted in the past, what I’d like to see happen is for G-Wizard to be built into Carbide Create/MeshCAM and for it to “just work” — I’d also like to have the ability to enter custom materials, say by adding characteristics such as hardness, friction co-efficient, &c. — again, that full-fledged physics simulation of cutting.

Oh well

1 Like

I upped my settings in G wizard to what my max was (197 IPM).
I have always run with these settings, and it never skips a beat, but excessive plunges will slow it down.
I dont know why yours keeps “defaulting”. Mine had no problem accepting my new settings.
I run an hour or 2 at a time, and the spindle does get pretty warm, but not too hot to touch.


I just went and played around with it some more and it appears as though it only resets when I switch between metric and Imperial. Metric and Imperial, the bain of my existence. I was raised in inches and work for a European company that works exclusively in metric, an aerospace company…almost everything aerospace is Imperial, we use standard MS, NAS, AN hardware, which of course is all Imperial. I’ve gotten pretty quick at converting over the past 13+ years, but it always seems like software asks for one or the other right when I’m trying to keep 10 numbers straight in my head, apparently it confuses GWizard as well, haha!!!