Spindle stalls almost immediately - SOLVED

Here’s a video where the spindle stalls during the plunge. I almost immediately hit the power button so the spindle never got a chance to move in X or Y. You can also see several cuts from previous attempts where the spindle made it farther before stalling.


What is the depth of the plunge? and what size bit and what material?

The material is the aluminum composite that’s supplied with the Nomad for the first tutorial. I’m using the suggested 1/8" flat bit. I don’t know the plunge depth. I used the program provided with the tutorial. I thinks it’s a binary.

Where did you set the zero? The surface of the spoil board, or the surface of the stock?

I set zero on the surface of the stock after taping it to the spoil board. I used the paper trick.


Here’s another video. Don’t watch it if you’re faint of heart…all safety rules were ignored but no fingers were lost.

The video shows me running the wrench tutorial program. When the spindle starts up I’m able to stop it with my finger very easily. Once it’s stopped, it won’t start spinning again unless I shut down the mill and restart it…even if I go to the jog menu and start it from there.


It definitely shouldn’t do that! Contact C3D support. @Jorge will sort you out in no time.

Pretty scary video!

In jog mode in CM I can stop my spindle very easily with my fingers but it spins back up afterwards. However, I didn’t try stopping it while it was trying to run a job. Its possible that the software shuts things down if it detects the spindle stopped during a job.

Does your spindle spin freely when you spin it by hand with the power off?

The process for getting help from Carbide3D is to submit the problem to their support@carbide3d.com email address. I don’t care for that approach but they aren’t set up to deal with issues any other way.

The video shows me running the wrench tutorial program. When the spindle starts up I’m able to stop it with my finger very easily. Once it’s stopped, it won’t start spinning again unless I shut down the mill and restart it…even if I go to the jog menu and start it from there.

Mine spindle act the same way. Until now I though it was normal, but maybe it is connect to my issue with the nomad.
Hopefully the support will answer in the next few days.

BTW what is your serial number @trichardson? Mine is 245 (Nomad 883 Pro).

Tony - The spindle spins ‘freely’. It doesn’t feel tight but it does take effort to overcome the magnets in the motor. Thanks for the instructions for getting customer service. I’ll submit an email in a sec.

Pascal - My serial number’s 283.

So, after stalling the spindle and breaking a few mills, I ended up with the spindle in a state it wouldn’t start, or would run at a weird speed (stick with me). Seemed to be a few 100 rpm, nowhere near the 10k it was set for. So, I broke the rules, reached in, and gave the large pulley a whirl with my finger. That apparently got the sensors in sync with what the driver was expecting, it came up to speed, and has been fine since.

I think there is a problem with the hall effect sensors getting out of sync with the spindle when you crash it sometimes. I’ve had this happen a couple times, and it seems to correct with a little help. I think I tried giving it a spin when it was stopped once, and then running the program and it came up just fine, but I can’t remember.

Whether this is -your- problem or not, have no idea, but its a data point.

Mike - I’ll give that a try and report back.


I tried to stall my spindle with moderate resistance while running a job (before it engaged the material) and it had substantially more torque than it did in Jog mode and I couldn’t stop it. At least not without putting more pressure than I was comfortable with.

I think you may have a bad driver card but it could be something else too. I’m sure C3D will get you taken care of though. There’s really not much to any of these machines so its relatively easy to fix anything that goes wrong just by replacing a part or two. Hope you get a fix quickly. Let us know what it was once you get it figured out.

Torque is very low when spinning slowly,

While jogging, rpm is less than about 1000 rpm (motor to spindle is between 2:1 and 3:1, so at 10000 rpm, motor is turning less than 4000 prm, at 2000 rpm at the spindle, the motor is running about 800 rpm give or take) That puts the motor at about .0025 Nm. For non-metric enabled, that’s about 0.022 inch pounds. You can probably stop that pretty easily with your fingers (but you shouldn’t stick your fingers in there…just sayin’).

Thanks mikep. One chart is worth a thousand words :wink:

I wasn’t jogging when I stopped it with my hands. I did that at the beginning of a program once the spindle had spun up. It should have been at cutting RPM.


I think it was. I think you probably have a bad driver board but that’s just a guess.

Everyone who guessed ‘bad driver board’ had it. Jorge sent me a new board and a brass pulley. I put the board in and the first tutorial completed flawlessly. I’ll put the pulley in tomorrow and do the rest of the tutorials.

Anyway, big ups to Jorge at Carbide for quickly taking care of this for me!



I am having the same problem, the spindle stops as it plunges into aluminum (5052) . I am a newbie with the Nomad. I have tried to increase the RPM to max. and decreased the plunge rate to 2 IPM but it still stalls. I am just trying to drill three .125 " holes in a piece .200" aluminum The machine seems to have very little torque.


Hi Bob,

do you use end mills or drills to drill. From my experience a plunge rate of 2 IPM ist still to fast for an end mill.
My fastest setup at the moment uses 1 IPM.
End Mills are made for horizontal movement. If you want to move just vertical, a drill is the better choice.


1 Like