Squaring Shapeoko 5 pro

Hi all, Dutch newby here, posting my first question. Hope you can help.

I just started exploring the basics on my new 4x4 Shapeoko 5 pro (what a beast!).

I noticed some inaccuracies and ran a few basic shapes. Clearly my circles are not circles…

I also noticed the gantry not being square to the Y-axis (at the end of a job).

What I’ve done so far;

  • measured diagonals (they are even)

  • unscrewed the gantry and re-tighten it, to make sure the gantry is engaged with the reference edge (manual p 10/11).

  • tighten all screws I could find :wink:

  • repositioned the limit switches on the y-axis one by one.

After each step, I cut another circle… nothing changed!

Anyone any idea on how to square the Shapeoko 5 Pro? Thanks!

First, check the machine mechanically — is all the hardware holding the linear motion components secure?

Verify this by installing a 1/4" probing pin in your spindle, then pushing and pulling on it — if the machine moves, note how/where and investigate and address.


Hi there, Did you tighten the Ball Screw Coupling Set Screws? There are 2 on each coupling, one for the motor and the shaft. You also need to make sure the screws are on the flat part of the shaft. (one for each axis)

1 Like

Looks like slop in the X axis. Z is shifting when X changes direction. Had the same issue. For me it ended up being the two screws that attach the Z to the X ball nut.

Power up your 5 so the motors are locked. Check your X, Y, and Z for movement by simply grabbing them and giving a good push and pull.


Wow guys, that was a quick response! I just solved it thanks to all three of you.

Powered up, push and pull: there was still some movement of the gantry on left Y-axis. I tightened the screws on the Y-motor (see picture) onto the ball screw and that solved the problem. Thank you so much, what a great community.

Before and after…beautiful circles!