Stepper motor not responding

Hey guys, went to run a job this morning to find that my x axis is not responding. I tried homing the machine (I have the xxl) y and z moved fine, but not x. I disabled homing so I could try to jog manually, that didn’t work. Also, when I go to move the spindle along the x axis when the power is off, the motor has a lot more resistance than it usually does. It has sticky spots if that makes sense. The y travels fine, but not the x. So I suspected a bad motor. Then, I looked through the forum and saw a suggestion to swap out the z and x leads just to see if it worked, and it does work. So, the motor seems off a bit but it works when connected to z. So that suggests maybe a driver? (Also learned from the forum) Trouble is, I don’t know what a driver is or how to fix it.

Any suggestions? I have an email into support already.

Please help,


The driver is on the controller board, and it’s not a replaceable component, so the whole board will need to be swapped.

For now, let’s wait to hear back from support and see what they suggest.


What would cause this? I was honestly using it yesterday and it was working fine. Is it something that just goes?

if you have a extension cable connection in the drag chain check that. Mine went bad from all the bending and i had to cut it out and just solder the connections.

1 Like

Thanks man, I will give that a shot tomorrow. Will has suggested that as well. Unfortunately, it looks like I need a new board and a cable. :frowning:

What causes this fail? I orderd a new board. And I checked the wiring extension for broken wires and it seems fine. My worry is installing the new board and it failing again. Is the driver something that can just “die”? Is a broken wiring extension the only thing that can cause this?