Stepper motor troubles (FIXED)

This is one:

The problem is the specific length of wire and connector which are used — not aware of a source which has those.

It’s pretty rare for the motors to go bad, usually it’s a wiring extension or a stepper driver (swap parts around to be sure of which) — no matter which part it is, contact us at and we’ll work out how to get you replacements.

Thanks Will, support request sent.

Dumb question, is the stepper driver you refer to on the C3D board?

Not a dumb question, and yes.

1 Like

Griff - I had this issue and the problem ended up being the connector to the stepper had a burned up pin. The motor was fine. So I recommend swapping connector wires if possible to see if the problem follows the motor or the cable.


Thanks, I’ll check it out

Not quite the same problem as yours but similar.

Will was right as usual. :roll_eyes: I’m embarrassed to say, it was an intermittent connection issue, not the stepper motor.

When I upgraded my machine to XL I cut and spliced the cable for the left Y motor. I soldered and double heatshrinked all the connections. It so happened that the section of cable the soldered connection is in is the section that gets flexed the most in the Y rail drag chain. So, sometimes the cable worked ok when connected to another motor. I finally connected Y right cable to Y left motor, it worked fine. Hmmmm, not the motor. I re-connected Y-left cable to Y-left motor, it worked fine…for 4” then the juddering again.

Pulled the drag chain apart and inspected the molex connector, no obvious damage. Then I found the soldered splice I’d forgotten about and carefully removed the heat shrink to find the green wire splice broken.

Cut all the leads, stripped to nice clean wire, re-soldered and heatshrinked.



I know this is an old thread. I remembered it as soon as I just had the issue on my 2015 SO3, upgraded to an XL when that was a new thing.
You can see the black burn mark on the housing where I removed the pin. The other side of the connector showed signs of melting.

So, I knew where to look, and I can put a new connector, but I’d like to know why this happens. Is it simply due to an inconsistent connection, maybe a broken solder joint on the odd choice of connector?
It was clearly hot at the connector. I could feel the heat just holding my hand above the drag chain in that spot.

Typically, there is some problem that creates a high-resistance connection, perhaps corrosion or dirt. Then, arcing starts, and it’s the arcing that does all the damage. Arcing can also create even more corrosion and resistance, leading to even more arcing etc etc etc.


Can also be size difference between the pins and sockets. A 2mm pin in a 2,54mm socket will be too loose, start arcing and eventually generate enough heat to melt/burn something.

1 Like

Continuing the discussion from Stepper motor troubles (FIXED):

I just removed the rest of these connectors a week or so ago, so I now have no connectors left. I have soldered all of the wires. Every single motor connector on my machine eventually burned up. When that happens the machine can and will go crazy in the middle of a cut. I ruined a couple of pieces before I found two more connectors had this issue. So I believe I now have removed all of them. I also make sure to turn off the controller. I used to have a bad habit of leaving the controller on all the time, which means those steppers were energized all the time. Probably not wise give this issue.

I mounted my connectors so that they are unmoving as noted at:

1 Like

Those connectors are not designed to be in a moving environment, they have no integral strain relief which would contribute to the contacts opening up over time.

It’s worth noting however, neither are solder joints, when wire is soldered this creates a strain point at the boundary between the solid soldered part and the stranded part which will also fail over time with flexing. Also, solder joints corrode over time with current and moisture, a good crimp connection beats a solder connection in many use cases.


What @LiamN said plus, I eventually replaced all the wiring with shielded, grounded wiring soldered to short, restrained pigtails at each stepper. To eliminate flexed connections. And, I never suffered another disconnect.


Worse than that…the male side is a PCB connector.
Knowing me, I’ll probably use lever nuts as a temporary solution which will then become permanent until I have another issue.


I’d lay the blame squarely on this:

Looking at this photo from earlier:

It looks like you just soldered some stranded wire to a KK 396 PCB header. Soldered stranded wire is very brittle and in a vibration-prone environment, that “joint” is going to deterioriate rapidly, leading to the high-resistance situation others mentioned.

I’d recommend replacing that connection with a small adapter PCB. It’ll cost you like $5 for JLCPCB or PCBWay and you can turn those ugly KK 396 connectors into something less horrible like Micro-Fit.

The other culprit could be crimping. If the leads aren’t properly terminated, you can see similar problems. I wouldn’t expect that from a factory machine though.

1 Like

Keep in mind the original SO3’s we bought back in 2014 were $972 as I recall. Entry level CNC’s. Some compromises I’m sure. Like the MOLEX connectors.

C3D has come a LONG way…


Not me, man.
I know the origin of the issue lies there. I wasn’t aware of the arcing.
The same thing happens on 3D printers, but I’ve never seen scorched wires and connectors.
Could this be damaging to the stepper drivers?

Wait, if not you then who? Did Carbide 3D sell a machine like that? Is that what you meant @Griff? I assumed this was just a hack to use another controller or something…

Electrically, I don’t think so. From the perspective of the stepper drivers, all that will happen is that the resistance increases, so less current makes it through. Eventually there will be a disconnect which should be fine.

The only danger I think is excessive heat being conducted back to the stepper driver through the cable.


Pretty sure those were the extensions on the original SO3–>XL upgrade.
Mine made it a few years longer than @dtilton71’s
I always knew I needed to do something about the wiring, but it always worked and I have lots of bad excuses.


Each time I’ve worked w/ the wiring on my XL, I’ve done my best to ensure that the connectors were firmly mounted in a location which minimized or eliminated if possible the movement of the wiring leading into them.