Still no tool RPM in .nc file

Hi, I’ve noticed that the gcode file still only has S1 (I think it used to put in a S5000) for the spindle RPMs instead of using the RPM from the tool crib or tool path selected. There is also no M3 or M5 to turn it on and off. I can of course edit the file and put them in but thats a pain.

What are you picking as your post processor. In CC Pro there is Nomad, Shapeoko, Generic gcode and GRBL. I have used the Shapeoko for Shapeoko 3xxl and the Generic Gcode and GRBL for my Shark. In all three there were the M commands and the speeds so dont know why you are not getting any of those commands in your gcode. Are the tools you are using listed in the Carbide3d data bases or are they custom tool library?

1 Like

I’ve tried both inbuilt and custom tools as well as metric and imperial post processors and none have RPMs or spindle commands. Here are snippets from the top of 2 test files.
(FILENAME: /Users/user/Documents/CNC/CNC Images/Flower Panel/
(STOCK/BLOCK, 140.000, 460.000, 14.000, -0.000, -0.000, 14.000)
M6 T2
(FILENAME: /Users/user/Documents/CNC/CNC Images/Flower Panel/
(STOCK/BLOCK, 5.512, 18.110, 0.551, -0.000, -0.000, 0.551)
M6 T103

So I looked at the CC post processor and it includes the S, M3 and M5 commands, I’ll just change the basic gcode post processor to include these.

So I did some more investigating and the RPM from the Toolpath window is not being used, the RPM in the SXXX in the gcode is from the data in the tool library, I tried both the CC and basic gcode metric options for the post processors and get the same result. This is a pain if you want to use another RPM when the material being machined is different from what was used when the tool in the library was being set up. the GRBL PP is even worse.
M3 S7500

This topic was automatically closed after 30 days. New replies are no longer allowed.