Streamlining Workflow for a 250 Sheet / Setup Job

Since this job is so big it might be better to break it into smaller chunks. If something goes wrong you start the section over without starting all over from the beginning. As long as you dont power off the Shapeoko the zeros will hold. If you power off recheck zero due to small variance in homing. The zeros may be dead on but check.

1 Like

In addition to @gdon_2003 's comment about making manageably-small batches (25 each may be a good compromise?) I would check upfront what the resulting NC file size would be with those 500 toolpaths in it. If you end up with a file in the several-hundred-Megabytes range, and while I seem to remember Carbide Motion was optimized at some point to allow for virtually unlimited file size (as long as there is enough memory available, that is), I would maybe not risk it.

Depending on how deep you are willing to go into that rabbit hole, you should be able to customize the post-processor in Fusion360 to automatically add a G0 line with suitable coords to move the gantry out of the way between each set of 2 toolpaths. Pro tip: challenge @neilferreri to do it and wait :wink:


so today I tried a little beta test of using “Create NC program” in F360 on a piece of shop furniture I needed to make and it DIDN’T work. Or at least it isn’t as simple as clicking my 3 setups and followed by “Create NC Program”.

After cutting the first toolpath in Setup 1 it jump right to the next toolpath in Setup 2 with no pause in-between for anything. Both Bitzero and BitRunner are disabled.

What happened here?: (20.6 KB)

How about adding a Manual NC Stop at the end of each setup? It will add an M0 pause between toolpaths.


Didn’t know you could do that, Will give that a shot next. Can going “home” or just back left or right be accomplish the same way?

Not quite, but it could probably be done in the Post Processor. I’ll look at it tonight or sometime tomorrow and see what I can come up with.

OK, if you’re not using a BitRunner, another automatic spindle control, or you’re ok with manually turning off the router between Setups this should help.

Instead of a Manual NC “Stop” at the end of each Setup (except the last), use a Manual NC “Pass Through” with a “Message” as below. This will retract and move to back right before the Pause.
You’ll need to use a capable Post Processor. Here’s the one I just modified. (5.7 KB)

Make sure to test the output first please. Here is a sample file to play with (note: No attention was paid to the actual feeds/speeds/DOCs/etc in this file as I never meant to actually cut anything)
Multiple Setups (80.7 KB)


Hi Neil, didn’t see this edit until now; I’ll give it a go this weekend and let you know. Thanks

1 Like

@neilferreri I gave it a go cutting some air on my OWN file and your Ferrari Post Processor and between setup 1 and setup 2 it just decided that it needed to plunge below the Z zero point.

I assume this is because this box is checked?

Please note that when I go into your test file and try and view the setttings of your NC program it just looks like this so if you’ve modified those checkboxes I’m unable to tell :

EDIT I’ve tried with that checkbox on and/off and it does it regardless which begs the question why is it doing it and looking closer isn’t that what your Manual NC is instructing it to do?
PS it doesn’t go “home” before plunging past z=0

Hey @MarkDGaal,
Without looking at your file, I’m going to guess it’s a unit thing. I always use mm. If you’re using inches, G53 Z-5 will send your Z to the location five inches below the Z limit.
Change the -5 in your Pass Through commands to -0.2 and you should be good. If you ARE using mm, I’ll have to take a look later.

The return to Work Zero option just returns the cutter to XY zero at a safe height at the END of the job. That won’t matter, and I wrote the post to take units of measurement into account.

The Manual NC commands are passed straight to the machine, so it has no idea what units you are using.

I am using inches so that is a good guess.

I’m sure that would the problem then. Did you get a chance to try it with the 0.2?

Use Vectric software if possible. Would be much less hassle, imo. Good luck

@stanmckinnon Is there a way to generate one gcode file for multiple setups at once with a Vectric product?

Just got the opportunity to try, and YES it does work (so long as you initialize the machine with either mm or in set vs. flipping them interchangeably in the settings of CM).

This should work well, thanks. Time to scale it up to 50 sheets per program and press run!


I’m looking forward to the progress! Go big or go home, right?

Wish me luck!

PS had I wanted to use Bitrunner to turn everything off between setups… could we just add something to the end of the pass through?

Before the M0 pause, you could add an M5.
You’d need to start the spindle again after you resume. Another Manual NC program at the beginning of the next toolpath with an M3 should do it. I’ll look to see if there is a way to handle that in the post processor.

per the bitrunner documentation… ?

“An M3 S command of 1000 or greater
(1000 is the RPM) automatically turns
the router on. M3 S2800 is an example M3 S command. Alternately, you might see commands
written like this: M3S2800.”

If you never changed the speed, it should remain what it was. No harm in adding the S18000, though.


G53 G0 Z-0.2,G53 G0 X-0.2 Y-0.2,M5,M0

did not shut if off before moving to “home”

Which is odd because… when you press “pause” in CM it shuts it off so even absent the M5 shouldn’t the M0 cause it to pause and turn off too?