Testing PWM Output

I’ve got a new Shapeoko XL with a 2.4e CMB. I installed pins for PWM and GND to wire up a VFD as discussed in numerous posts.

I’m running CM4 build 416. Start/Stop Spindle has no effect in CM. I’ve tried Manually sending M3S10000 and M5 in MDI, no joy. I can see in the log that it’s being passed to the controller, but has no effect.

I’ve checked and rechecked VFD settings. I’ve reset the VFD and re-entered all the settings just to be sure on that end. Not ruling it out, but pretty sure the VFD itself is not the issue.

When I send a Start, I’m not measuring ANY voltage on PWM. I’ve tried sending different speeds in MDI just to see if I’d get something, but no change. I’ve tried two different meters, so I’m pretty sure PWM is just…dead…but I’m going to try an LED tomorrow.

In the meantime, does anyone have any good ideas for troubleshooting this thing? Is there something unique in CM4 build 416 that I need to enable or do that I’m missing? All the references I can find online suggest that aside from adding the pins to PWM and GND, there is nothing else I need to do on the CMB or in CM4 to make this work. Has anything changed? Thanks.

1 Like

Have you entered your spindles max/min RPM in the GRBL settings ($30 and $31)?


I second that guess, I had a similar (not identical) issue sometime ago, and fixed it by increasing $30:


Max Speed, yes. I’ll try the Min Speed setting just to make sure that isn’t it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.